summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/databases.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0f766e1738..00e26e4839 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -185,14 +185,14 @@
"4store-fix-buildsystem.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("perl" ,perl)
- ("python" ,python-2)
- ("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gettext" ,gettext-minimal)
- ("libtool" ,libtool)
- ("pcre" ,pcre "bin") ;for 'pcre-config'
- ("pkg-config" ,pkg-config)))
+ (list perl
+ python-2
+ autoconf
+ automake
+ gettext-minimal
+ libtool
+ `(,pcre "bin") ;for 'pcre-config'
+ pkg-config))
(inputs
(list glib
rasqal