summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-29 20:09:32 +0100
committerMarius Bakke <marius@gnu.org>2020-12-13 21:44:09 +0100
commitce29031a23104928155b498d552fc4140cc03030 (patch)
tree11ef3dea85f078481938f70c3c0205144a281812 /gnu/packages/databases.scm
parent6223566971031c7a7d22f5e3eeba5621bf1213f2 (diff)
downloadguix-patches-ce29031a23104928155b498d552fc4140cc03030.tar
guix-patches-ce29031a23104928155b498d552fc4140cc03030.tar.gz
gnu: MariaDB: Update to 10.5.8.
* gnu/packages/databases.scm (mariadb): Update to 10.5.8. [arguments]: Adjust #:configure-flags to not install tests; remove code for the same. Adjust phases for upstream test changes. Add workaround.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm27
1 files changed, 21 insertions, 6 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 4b1a1ff09d..bf9f31ad25 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -898,7 +898,7 @@ Language.")
(define-public mariadb
(package
(name "mariadb")
- (version "10.5.6")
+ (version "10.5.8")
(source (origin
(method url-fetch)
(uri (string-append "https://downloads.mariadb.com/MariaDB"
@@ -906,7 +906,7 @@ Language.")
version ".tar.gz"))
(sha256
(base32
- "1i257h0zdypdfj5wkg6ck9pxlkph0jvjs92k22pjr6gnx5lxs1gz"))
+ "1s3vfm73911cddjhgpcbkya6nz7ag2zygg56qqzwscn5ybv28j7b"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -956,6 +956,11 @@ Language.")
"-DDEFAULT_COLLATION=utf8_general_ci"
"-DMYSQL_DATADIR=/var/lib/mysql"
"-DMYSQL_UNIX_ADDR=/run/mysqld/mysqld.sock"
+
+ ;; Do not install the tests or benchmark suite.
+ "-DINSTALL_MYSQLTESTDIR=false"
+ "-DINSTALL_SQLBENCHDIR=false"
+
(string-append "-DCMAKE_INSTALL_PREFIX=" (assoc-ref %outputs "lib"))
(string-append "-DCMAKE_INSTALL_RPATH=" (assoc-ref %outputs "lib")
"/lib")
@@ -1005,8 +1010,15 @@ Language.")
"main.explain_non_select"
"main.stat_tables"
"main.stat_tables_innodb"
+ "main.upgrade_MDEV-19650"
"roles.acl_statistics"
+ ;; FIXME: This test checks various table encodings and
+ ;; fails because Guix defaults to UTF8 instead of the
+ ;; upstream default latin1_swedish_ci. It's not easily
+ ;; substitutable because several encodings are tested.
+ "main.sp2"
+
;; This file contains a time bomb which makes it fail after
;; 2030-12-31. See <https://bugs.gnu.org/34351> for details.
"main.mysqldump"))
@@ -1077,12 +1089,15 @@ Language.")
(("\\$basedir/share/mysql")
(string-append lib "/share/mysql")))
- ;; Remove unneeded files for testing.
(with-directory-excursion lib
- (for-each delete-file-recursively
- '("mysql-test" "sql-bench"))
- ;; And static libraries.
+ ;; FIXME: Something creates an empty gnu/store/xxx-mariadb/bin
+ ;; directory at the root of the lib output. It's not present
+ ;; in the installation log. This started occuring between
+ ;; 10.5.6 and 10.5.8. How to prevent it?
+ (delete-file-recursively "gnu")
+ ;; Remove static libraries.
(for-each delete-file (find-files "lib" "\\.a$")))
+
(with-directory-excursion out
(delete-file "share/man/man1/mysql-test-run.pl.1")
;; Delete huge and unnecessary executables.