summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-05 19:17:41 +0100
commit9bc0f45df5d6aed217020b1183dca54989844fb0 (patch)
treed927e89949ff7f65b5059bc94273c53fd43d0763 /gnu/packages/databases.scm
parent6db3c536e89deb8a204e756f427614925a7d2582 (diff)
parent10554e0a57feeea470127a1d0441957d1776b0bd (diff)
downloadguix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar
guix-patches-9bc0f45df5d6aed217020b1183dca54989844fb0.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index a817e1f9e2..6b552f688f 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3807,7 +3807,7 @@ the SQL language using a syntax that reflects the resulting query.")
(define-public apache-arrow
(package
(name "apache-arrow")
- (version "5.0.0")
+ (version "6.0.1")
(source
(origin
(method git-fetch)
@@ -3817,7 +3817,7 @@ the SQL language using a syntax that reflects the resulting query.")
(file-name (git-file-name name version))
(sha256
(base32
- "0275aayzy78nbxzbj93w5152sv5q2c7020ijxnf8b58v9qwfxzz0"))))
+ "0mcw361akqw4sxnnpnr9c9v1zk4hphk6gcq763pcb19yzljh88ig"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f
@@ -3856,6 +3856,10 @@ the SQL language using a syntax that reflects the resulting query.")
"-DARROW_DEPENDENCY_SOURCE=SYSTEM"
"-Dxsimd_SOURCE=SYSTEM"
+ "-DARROW_RUNTIME_SIMD_LEVEL=NONE"
+ "-DARROW_SIMD_LEVEL=NONE"
+ "-DARROW_PACKAGE_KIND=Guix"
+
;; Split output into its component packages.
(string-append "-DCMAKE_INSTALL_PREFIX="
(assoc-ref %outputs "lib"))
@@ -3897,23 +3901,25 @@ the SQL language using a syntax that reflects the resulting query.")
;;"-DBENCHMARK_ENABLE_TESTING=OFF"
"-DARROW_BUILD_STATIC=OFF")))
(inputs
- `(("apache-thrift" ,apache-thrift "lib")
- ("boost" ,boost)
+ `(("boost" ,boost)
("brotli" ,brotli)
("bzip2" ,bzip2)
("double-conversion" ,double-conversion)
("gflags" ,gflags)
("glog" ,glog)
("grpc" ,grpc)
- ("lz4" ,lz4)
("protobuf" ,protobuf)
("python-3" ,python)
("python-numpy" ,python-numpy)
("rapidjson" ,rapidjson)
("re2" ,re2)
("snappy" ,snappy)
+ ("xsimd" ,xsimd)))
+ ;; These are all listed under Requires.private in arrow.pc
+ (propagated-inputs
+ `(("apache-thrift" ,apache-thrift "lib")
+ ("lz4" ,lz4)
("utf8proc" ,utf8proc)
- ("xsimd" ,xsimd)
("zlib" ,zlib)
("zstd" ,zstd "lib")))
(native-inputs