summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-03 16:10:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-03 16:23:17 +0200
commit9930beb86084a40f17f71709d41f03338876feb3 (patch)
tree7fdc23b65930a25072fbafcf3e3af9fdfc9ca6ff /gnu/packages/databases.scm
parentaa5fadaf7234c6332eea81384fef3846c510c1d3 (diff)
downloadguix-patches-9930beb86084a40f17f71709d41f03338876feb3.tar
guix-patches-9930beb86084a40f17f71709d41f03338876feb3.tar.gz
gnu: python-apsw: Don't use unstable tarball.
* gnu/packages/databases.scm (python-apsw)[source]: Download using release zip archive. [native-inputs]: Add unzip.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 73b7dc7d3a..113e640739 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 ng0 <ng0@n0.is>
;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -2630,13 +2630,14 @@ PickleShare.")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/rogerbinns/apsw/archive/"
- version ".tar.gz"))
- (file-name (string-append "apsw-" version ".tar.gz"))
+ (uri (string-append "https://github.com/rogerbinns/apsw/releases"
+ "/download/" version "/apsw-" version ".zip"))
(sha256
(base32
- "00ai7m2pqi26qaflhz314d8k5i3syw7xzr145fhfl0crhyh6adz2"))))
+ "02mgxyznxg0va85r1lk6pvjh7qvar33fivj0bn534jb0yy271a9y"))))
(build-system python-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
(inputs
`(("sqlite" ,sqlite)))
(arguments