summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-21 20:55:11 +0100
committerMarius Bakke <marius@gnu.org>2022-01-22 10:23:00 +0100
commit84bcda58fc2d92f81088eb6f096609e209c94d4b (patch)
tree02a46e8a27257bcbc6c171593e85a64e5a00a40d /gnu/packages/databases.scm
parent8830d9f900f3dc2107a0ce9541312579fa6ccb6e (diff)
downloadguix-patches-84bcda58fc2d92f81088eb6f096609e209c94d4b.tar
guix-patches-84bcda58fc2d92f81088eb6f096609e209c94d4b.tar.gz
gnu: Add python-psycopg-pool.
* gnu/packages/databases.scm (python-psycopg-pool): New variable.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 6ca1f814de..0e0007ef65 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3439,6 +3439,33 @@ designed to be easy and intuitive to use.")
2.0.")
(license license:lgpl3+)))
+(define-public python-psycopg-pool
+ (package
+ (name "python-psycopg-pool")
+ ;; The connection pooling code is on a different release cadence
+ ;; from the driver code, so fetch the latest PyPI release.
+ (version "3.0.3")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "psycopg-pool" version))
+ (sha256
+ (base32
+ "1nx139pwzsgrz253zjxw2sf8h713s79h4cp1falmpc39j08djb46"))))
+ (build-system python-build-system)
+ (arguments
+ (list #:tests? #f ;run for psycopg below
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; This module requires 'psycopg', however psycopg needs this
+ ;; for its tests. Disable sanity check to break the cycle.
+ (delete 'sanity-check))))
+ (home-page "https://www.psycopg.org/")
+ (synopsis "Connection pooler for psycopg")
+ (description
+ "This module provides connection pool implementations that can be used
+with the @code{psycopg} PostgreSQL driver.")
+ (license license:lgpl3+)))
+
(define-public python-sadisplay
(package
(name "python-sadisplay")