summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-10 00:55:42 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-10 00:55:42 +0200
commit7a05fdd0e1d5e5e26e94014d87bf85575bbec780 (patch)
tree6f68b8832b4465c9aeee734997c168840b7b1ee0 /gnu/packages/databases.scm
parent36175a3a9eb5bd4096de4e06e1f6b0e8cd895d84 (diff)
parent760d90cc6a5c0f9eb46ad18a30da5520fac2525e (diff)
downloadguix-patches-7a05fdd0e1d5e5e26e94014d87bf85575bbec780.tar
guix-patches-7a05fdd0e1d5e5e26e94014d87bf85575bbec780.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 01ce5f1ae7..b5eb1845a5 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -92,6 +93,7 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
@@ -3080,3 +3082,24 @@ NumPy, and other traditional Python scientific computing packages.")
(define-public python2-pyarrow
(package-with-python2 python-pyarrow))
+
+(define-public python-crate
+ (package
+ (name "python-crate")
+ (version "0.23.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "crate" version))
+ (sha256
+ (base32
+ "0s3s7yg4m2zflg9q96aibwb5hizsn10ql63fsj6h5z624qkavnlp"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-urllib3" ,python-urllib3)))
+ (home-page "https://github.com/crate/crate-python")
+ (synopsis "CrateDB Python client")
+ (description
+ "This package provides a Python client library for CrateDB.
+It implements the Python DB API 2.0 specification and includes support for
+SQLAlchemy.")
+ (license license:asl2.0)))