summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-11 10:27:09 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-11 10:27:09 +0200
commit58bf51b4c0771fb6cfcf22be84d734096e7b11e0 (patch)
tree69c22625468b10e43fd37e7c5ddc420a1de6ab55 /gnu/packages/databases.scm
parent69ecd666d73ebc5ee7a0be54f4e24f000d1d7e31 (diff)
parentbf3005346e6538aba6d077c887f688779b94b274 (diff)
downloadguix-patches-58bf51b4c0771fb6cfcf22be84d734096e7b11e0.tar
guix-patches-58bf51b4c0771fb6cfcf22be84d734096e7b11e0.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 47eaac8e69..55f7a46dc5 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -33,6 +33,7 @@
;;; Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -108,6 +109,7 @@
#:use-module (guix download)
#:use-module (guix bzr-download)
#:use-module (guix git-download)
+ #:use-module (guix build-system emacs)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (guix build-system perl)
@@ -928,8 +930,7 @@ organized in a hash table or B+ tree.")
(assoc-ref %build-inputs "bash:include")
"/include/bash"))))
- (native-inputs `(("emacs" ,emacs-minimal)
- ("bc" ,bc)
+ (native-inputs `(("bc" ,bc)
("bash:include" ,bash "include")
("check" ,check)
("libuuid" ,util-linux)
@@ -948,6 +949,26 @@ types are supported, as is encryption.")
(license license:gpl3+)
(home-page "https://www.gnu.org/software/recutils/")))
+(define-public emacs-recutils
+ (package
+ (inherit recutils)
+ (name "emacs-recutils")
+ (build-system emacs-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'change-directory
+ (lambda _
+ (chdir "etc")
+ #t)))))
+ (native-inputs '())
+ (inputs '())
+ (synopsis "Emacs mode for working with recutils database files")
+ (description "This package provides an Emacs major mode @code{rec-mode}
+for working with GNU Recutils text-based, human-editable databases. It
+supports editing, navigation, and querying of recutils database files
+including field and record folding.")))
+
(define-public rocksdb
(package
(name "rocksdb")