summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-17 23:24:42 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-17 23:43:14 +0100
commit3a317f7476f8c6012e166ff9f340f861938721c9 (patch)
tree946e398c37912cfc03be7306951ae87bfeb130fa /gnu/packages/databases.scm
parente55547bf70384691712047912c793c517debd2ec (diff)
parent62e707d67caf1dab2af411a69ff8cec4b2dc686e (diff)
downloadguix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar
guix-patches-3a317f7476f8c6012e166ff9f340f861938721c9.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index b7ab4578f2..e11efaf152 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3049,13 +3049,13 @@ Database API 2.0T.")
(define-public python-sqlalchemy
(package
(name "python-sqlalchemy")
- (version "1.4.26")
+ (version "1.4.27")
(source
(origin
(method url-fetch)
(uri (pypi-uri "SQLAlchemy" version))
(sha256
- (base32 "06imr96jirwmkc8mkxrl9bi413yd3638lc5idn65xx8fv7bzkivb"))))
+ (base32 "031jbd0svrvwr3n52iibp9mkwsj9wicnck45yd26da5kmsfkas6p"))))
(build-system python-build-system)
(native-inputs
`(("python-cython" ,python-cython) ; for C extensions
@@ -3164,9 +3164,6 @@ You might also want to install the following optional dependencies:
")
(license license:bsd-3)))
-(define-public python2-sqlalchemy-utils
- (package-with-python2 python-sqlalchemy-utils))
-
(define-public python-alchemy-mock
(package
(name "python-alchemy-mock")
@@ -3401,13 +3398,13 @@ designed to be easy and intuitive to use.")
(define-public python-psycopg2
(package
(name "python-psycopg2")
- (version "2.8.6")
+ (version "2.9.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "psycopg2" version))
(sha256
- (base32 "0hzmk6b1hb5riqkljr5xics6p4zbvmis6knbczb7zhq7273zc8zv"))))
+ (base32 "1smvvs1ngqy0ymlp1d7f85j09j9v0z5dq14f1qky0j0qi7xajkd8"))))
(build-system python-build-system)
(arguments
;; Tests would require a postgresql database "psycopg2_test"
@@ -3422,9 +3419,6 @@ designed to be easy and intuitive to use.")
2.0.")
(license license:lgpl3+)))
-(define-public python2-psycopg2
- (package-with-python2 python-psycopg2))
-
(define-public python-sadisplay
(package
(name "python-sadisplay")