summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-11 23:23:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-11 23:23:00 +0200
commit2f9132e2e0b1e01398a01a32972e87f45ec2f7a6 (patch)
treee8cc581628bdcdf017032ae2b24f11757960d1d4 /gnu/packages/databases.scm
parent6dda22363166bc67e8846714cc947918692202c5 (diff)
downloadguix-patches-2f9132e2e0b1e01398a01a32972e87f45ec2f7a6.tar
guix-patches-2f9132e2e0b1e01398a01a32972e87f45ec2f7a6.tar.gz
Revert "Revert "gnu: mongodb: Update to 3.4.24 [security fixes].""
This reverts commit feff80cec3c97a3df2c20d300be12d67f79d4f22. I was mistaken, there are still branches of mongodb which are still licensed under the AGPL3
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 29270ce2be..aa64507b00 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -667,27 +667,24 @@ replacement for the code@{python-memcached} library.")
(define-public mongodb
(package
(name "mongodb")
- (version "3.4.10")
+ (version "3.4.24")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/mongodb/mongo/archive/r"
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0676lvkljj7a5hdhv78dbykqnqrj9lbn9799mi84b8vbnzsq961r"))
+ (base32 "0y1669sqj8wyf0y0njhxs4qhn1qzjhrs2h2qllya5samxrlrjhkg"))
(modules '((guix build utils)))
(snippet
'(begin
(for-each (lambda (dir)
(delete-file-recursively
(string-append "src/third_party/" dir)))
- '("pcre-8.41" "scons-2.5.0" "snappy-1.1.3"
+ '("pcre-8.42" "scons-2.5.0" "snappy-1.1.3"
"valgrind-3.11.0" "wiredtiger"
- "yaml-cpp-0.5.3" "zlib-1.2.8"))
- #t))
- (patches
- (list
- (search-patch "mongodb-support-unknown-linux-distributions.patch")))))
+ "yaml-cpp-0.6.2" "zlib-1.2.11"))
+ #t))))
(build-system scons-build-system)
(inputs
`(("openssl" ,openssl-1.0)