summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-24 22:48:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-24 22:48:59 +0200
commit224d2e2efd1ccefaab0e3c10b0ab07451f436d27 (patch)
tree5a3419e2aba19426b98da731b13a26e374f2a196 /gnu/packages/databases.scm
parentddb4062784c66ecc0c42910b209dc80356a197ea (diff)
downloadguix-patches-224d2e2efd1ccefaab0e3c10b0ab07451f436d27.tar
guix-patches-224d2e2efd1ccefaab0e3c10b0ab07451f436d27.tar.gz
gnu: postgresql: Remove graft for 10.8.
* gnu/packages/databases.scm (postgresql): Update to 10.8. [replacement]: Remove. (postgresql-10.8): Remove variable.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm21
1 files changed, 2 insertions, 19 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 96b58b3a40..ea0a38b626 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -800,15 +800,14 @@ as a drop-in replacement of MySQL.")
(define-public postgresql
(package
(name "postgresql")
- (version "10.7")
- (replacement postgresql-10.8)
+ (version "10.8")
(source (origin
(method url-fetch)
(uri (string-append "https://ftp.postgresql.org/pub/source/v"
version "/postgresql-" version ".tar.bz2"))
(sha256
(base32
- "1piyfcrcqscjhnnwn91kdvr764s7d0qz4lgygf9bl6qc71ji1vdz"))
+ "0pfdmy4w95b49w9rkn8dwvzmi2brpqfvbxd04y0k0s0xvymc565i"))
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
(build-system gnu-build-system)
(arguments
@@ -844,22 +843,6 @@ TIMESTAMP. It also supports storage of binary large objects, including
pictures, sounds, or video.")
(license (license:x11-style "file://COPYRIGHT"))))
-;; This release fixes CVE-2019-10129 and CVE-2019-10130. See
-;; <https://www.postgresql.org/about/news/1939/> for details.
-;; TODO: Remove this in the next rebuild cycle.
-(define-public postgresql-10.8
- (package
- (inherit postgresql)
- (version "10.8")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ftp.postgresql.org/pub/source/v"
- version "/postgresql-" version ".tar.bz2"))
- (sha256
- (base32
- "0pfdmy4w95b49w9rkn8dwvzmi2brpqfvbxd04y0k0s0xvymc565i"))
- (patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))))
-
(define-public postgresql-9.6
(package
(inherit postgresql)