summaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2020-10-02 19:08:35 +0100
committerChristopher Baines <mail@cbaines.net>2020-10-20 22:39:43 +0100
commit21b712acc73f6a0a8f9d44ae32438539b78b3db6 (patch)
tree0b17ef189c7731420f6198063844ac83c3be0f46 /gnu/packages/databases.scm
parenta698df72d37aa5173c357b7d1e3873d2c2c64c32 (diff)
downloadguix-patches-21b712acc73f6a0a8f9d44ae32438539b78b3db6.tar
guix-patches-21b712acc73f6a0a8f9d44ae32438539b78b3db6.tar.gz
gnu: databases: Define postgresql-10.
So that it can be used, rather than postgresql. Because the major version of the package is important, as it relates to the compatability with the data files used by the service, it's useful to have a stable name to refer to a package for version 10 of PostgreSQL. * gnu/packages/databases.scm (postgresql-10): New variable.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 1236f57018..0d8342b04a 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1040,6 +1040,8 @@ TIMESTAMP. It also supports storage of binary large objects, including
pictures, sounds, or video.")
(license (license:x11-style "file://COPYRIGHT"))))
+(define-public postgresql-10 postgresql)
+
(define-public postgresql-11
(package
(inherit postgresql)