summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-22 21:11:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-22 22:12:33 +0100
commitf5fa1a77c76376d2cfe5af13578bb74b2f2a67af (patch)
tree124d612e133b017b93f47ee77d7deb790997dbf7 /gnu/packages/curl.scm
parent6ab31af7c7fae218388b624af6c092d72b12c5b3 (diff)
downloadguix-patches-f5fa1a77c76376d2cfe5af13578bb74b2f2a67af.tar
guix-patches-f5fa1a77c76376d2cfe5af13578bb74b2f2a67af.tar.gz
gnu: curl: Remove unnecessary reference to the "doc" output.
* gnu/packages/curl.scm (curl)[arguments]: Add #:disallowed-references. Add phase to prevent configure flags from being stored in the output.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index b2884ddd82..b06d01c7d7 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2017, 2019 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2017, 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
@@ -93,13 +93,20 @@
(separator #f) ;single entry
(files '("etc/ssl/certs/ca-certificates.crt")))))
(arguments
- `(#:configure-flags (list "--with-gnutls"
+ `(#:disallowed-references ("doc")
+ #:configure-flags (list "--with-gnutls"
(string-append "--with-gssapi="
(assoc-ref %build-inputs "mit-krb5"))
"--disable-static")
- ;; Add a phase to patch '/bin/sh' occurances in tests/runtests.pl
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'do-not-record-configure-flags
+ (lambda _
+ ;; Do not save the configure options to avoid unnecessary references.
+ (substitute* "curl-config.in"
+ (("@CONFIGURE_OPTIONS@")
+ "\"not available\""))
+ #t))
(add-after
'install 'move-man3-pages
(lambda* (#:key outputs #:allow-other-keys)