summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorImran Iqbal <imran@imraniqbal.org>2022-03-24 01:05:11 -0400
committerLudovic Courtès <ludo@gnu.org>2022-03-25 12:21:23 +0100
commitf2bbe73b817f2dc5a3ca866a750ce71737c12de2 (patch)
tree47d8e9e2bfaf78c27d669a339537b757b2c2c18f /gnu/packages/curl.scm
parent72d2aeacaa5039d0ddc69ba531d39d5903d81459 (diff)
downloadguix-patches-f2bbe73b817f2dc5a3ca866a750ce71737c12de2.tar
guix-patches-f2bbe73b817f2dc5a3ca866a750ce71737c12de2.tar.gz
gnu: Add curlie.
* gnu/packages/curl.scm (curlie): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index d36519260e..021a3afcce 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -362,3 +362,31 @@ curl to obtain exactly that HTTP request.")
(description "Coeurl is a simple library to do HTTP requests
asynchronously via cURL in C++.")
(license license:expat)))
+
+(define-public curlie
+ (package
+ (name "curlie")
+ (version "1.6.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rs/curlie")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1kmp8kd5sahb7x01pkk80zs7dvsnziavjlk2igis499a3ddcjqmr"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/rs/curlie"))
+ (inputs
+ (list curl go-golang-org-x-crypto go-golang-org-x-sys))
+ (home-page "https://curlie.io")
+ (synopsis "The power of curl, the ease of use of httpie")
+ (description "If you like the interface of HTTPie but miss the features of
+curl, curlie is what you are searching for. Curlie is a frontend to
+@code{curl} that adds the ease of use of @code{httpie}, without compromising
+on features and performance. All @code{curl} options are exposed with syntax
+sugar and output formatting inspired from @code{httpie}.")
+ (license license:expat)))