summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2020-10-08 09:21:40 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2020-10-08 10:06:12 +0200
commitcde87f38cf535d717fd46b19b988404d52f02c59 (patch)
tree6764d0a978315ef2ab0daaa52c9829c1e7a8338c /gnu/packages/curl.scm
parent9e4a193b099fc4c8671891320adafe422d0d2f24 (diff)
downloadguix-patches-cde87f38cf535d717fd46b19b988404d52f02c59.tar
guix-patches-cde87f38cf535d717fd46b19b988404d52f02c59.tar.gz
gnu: curl: Update to 7.72.0.
* gnu/packages/curl.scm (curl): Update to 7.72.0. [native-inputs]: Add nghttp2.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 6e08a64e82..6b507f7b5b 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -53,14 +53,14 @@
(define-public curl
(package
(name "curl")
- (version "7.71.1")
+ (version "7.72.0")
(source (origin
(method url-fetch)
(uri (string-append "https://curl.haxx.se/download/curl-"
version ".tar.xz"))
(sha256
(base32
- "13357690bgr533dd49k0blwvkwcscgxwwj6ssifb5gnd4zd3xy20"))
+ "04rpa53c6wycjrhldnm9kig1d7fc23k0m646vgh2wpyqqh40iv8d"))
(patches (search-patches "curl-use-ssl-cert-env.patch"))))
(build-system gnu-build-system)
(outputs '("out"
@@ -72,7 +72,8 @@
("nghttp2" ,nghttp2 "lib")
("zlib" ,zlib)))
(native-inputs
- `(("perl" ,perl)
+ `(("nghttp2" ,nghttp2)
+ ("perl" ,perl)
("pkg-config" ,pkg-config)
("python" ,python-wrapper)))
(native-search-paths