summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorDale Mellor <guix-devel-0brg6b@rdmp.org>2020-06-21 23:53:07 +0100
committerLudovic Courtès <ludo@gnu.org>2020-07-03 23:53:32 +0200
commitcce8ab8d80b8ceefaf05fdd701330ccf1ab5f012 (patch)
tree49d9c84b7bca5b23a4c0967ca66e06905390a8d2 /gnu/packages/curl.scm
parent21064f095e350be9599ef327e3b1f2991fab196d (diff)
downloadguix-patches-cce8ab8d80b8ceefaf05fdd701330ccf1ab5f012.tar
guix-patches-cce8ab8d80b8ceefaf05fdd701330ccf1ab5f012.tar.gz
gnu: Add curlpp library.
* gnu/packages/curl.scm (curlpp): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index bf93639716..b0bdd6ded6 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 Dale Mellor <guix-devel-0brg6b@rdmp.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module (guix utils)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (gnu packages)
@@ -284,3 +286,34 @@ not offer a replacement for libcurl.")
Guile to do client-side URL transfers, like requesting documents from HTTP or
FTP servers. It is based on the curl library.")
(license license:gpl3+)))
+
+(define-public curlpp
+ (package
+ (name "curlpp")
+ (version "0.8.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jpbarrette/curlpp.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1b0ylnnrhdax4kwjq64r1fk0i24n5ss6zfzf4hxwgslny01xiwrk"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ ;; There are no build tests to be had.
+ (arguments
+ '(#:tests? #f))
+ ;; The installed version needs the header files from the C library.
+ (propagated-inputs
+ `(("curl" ,curl)))
+ (synopsis "C++ wrapper around libcURL")
+ (description
+ "This package provides a free and easy-to-use client-side C++ URL
+transfer library, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET, DICT,
+FILE and LDAP; in particular it supports HTTPS certificates, HTTP POST, HTTP
+PUT, FTP uploading, kerberos, HTTP form based upload, proxies, cookies,
+user+password authentication, file transfer resume, http proxy tunneling and
+more!")
+ (home-page "http://www.curlpp.org")
+ (license license:expat)))