summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-21 19:14:18 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-21 19:23:47 +0100
commitc1f4e6491cecc5d121ef371a8fb2aa0a07030d36 (patch)
treebb4b7ef154cf0b7c84d118aed0273d0ba755a506 /gnu/packages/curl.scm
parentaf8f7eb4f2a664c2d0fb3faabaf2e80c72993ef6 (diff)
downloadguix-patches-c1f4e6491cecc5d121ef371a8fb2aa0a07030d36.tar
guix-patches-c1f4e6491cecc5d121ef371a8fb2aa0a07030d36.tar.gz
gnu: curl: Restore derivation.
Commit af8f7eb4f2a664c2d0fb3faabaf2e80c72993ef6 accidentally changed the cURL derivation. Remove use of HIDDEN-PACKAGE and restore input order to prevent a large number of rebuilds. * gnu/packages/ssh.scm (libssh2-1.8.0): Move from here ... * gnu/packages/curl.scm (libssh2-1.8.0): ... to here. Don't use HIDDEN-PACKAGE and make it non-public. (curl)[inputs]: Move LIBSSH2-1.8.0 where it was before af8f7eb4f2a66.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm25
1 files changed, 21 insertions, 4 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index a36a1ee4a6..041853c6f3 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -48,6 +48,23 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages web))
+;; XXX A hidden special obsolete libssh2 for temporary use in the curl package.
+;; <https://bugs.gnu.org/34927>
+(define libssh2-1.8.0
+ (package
+ (inherit libssh2)
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://www.libssh2.org/download/libssh2-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1m3n8spv79qhjq4yi0wgly5s5rc8783jb1pyra9bkx1md0plxwrr"))
+ (patches
+ (search-patches "libssh2-fix-build-failure-with-gcrypt.patch"))))))
+
(define-public curl
(package
(name "curl")
@@ -66,14 +83,14 @@
(inputs `(("gnutls" ,gnutls)
("gss" ,gss)
("libidn" ,libidn)
- ("openldap" ,openldap)
- ("nghttp2" ,nghttp2 "lib")
- ("zlib" ,zlib)
;; TODO XXX <https://bugs.gnu.org/34927>
;; Curl doesn't actually use or refer to libssh2 because the build
;; is not configured with '--with-libssh2'. Remove this input when
;; a mass rebuild is appropriate (e.g. core-updates).
- ("libssh2" ,libssh2-1.8.0)))
+ ("libssh2" ,libssh2-1.8.0)
+ ("openldap" ,openldap)
+ ("nghttp2" ,nghttp2 "lib")
+ ("zlib" ,zlib)))
(native-inputs
`(("perl" ,perl)
;; to enable the --manual option and make test 1026 pass