summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-27 13:42:25 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:22 -0500
commita248421cbdd27730f436c76aefe322b3091d88b6 (patch)
treef4e3f8751447dcb405ec6a31bf52dc219117be64 /gnu/packages/curl.scm
parente976789754c0af63aef4acea18971c9f41ed2826 (diff)
downloadguix-patches-a248421cbdd27730f436c76aefe322b3091d88b6.tar
guix-patches-a248421cbdd27730f436c76aefe322b3091d88b6.tar.gz
gnu: curl: Update to 7.79.1.
* gnu/packages/curl.scm (curl): Update to 7.79.1. Delete trailing #t. [origin]: Remove the upstream curl-7.77-tls-priority-string.patch patch. * gnu/packages/patches/curl-7.77-tls-priority-string.patch: Delete it. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 4c90c7b301..6d2f36397f 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -57,16 +57,15 @@
(define-public curl
(package
(name "curl")
- (version "7.77.0")
+ (version "7.79.1")
(source (origin
(method url-fetch)
(uri (string-append "https://curl.haxx.se/download/curl-"
version ".tar.xz"))
(sha256
(base32
- "0jsrc97vbghvljic997r9nypc9qqddcil2lzvv032br8ahn5hr0g"))
- (patches (search-patches "curl-use-ssl-cert-env.patch"
- "curl-7.77-tls-priority-string.patch"))))
+ "129n9hi7rbg3s112chyadhp4y27ppb5i65n12wm77aw2255zf1h6"))
+ (patches (search-patches "curl-use-ssl-cert-env.patch"))))
(build-system gnu-build-system)
(outputs '("out"
"doc")) ;1.2 MiB of man3 pages
@@ -112,8 +111,7 @@
;; Do not save the configure options to avoid unnecessary references.
(substitute* "curl-config.in"
(("@CONFIGURE_OPTIONS@")
- "\"not available\""))
- #t))
+ "\"not available\""))))
(add-after
'install 'move-man3-pages
(lambda* (#:key outputs #:allow-other-keys)
@@ -122,8 +120,7 @@
(doc (assoc-ref outputs "doc")))
(mkdir-p (string-append doc "/share/man"))
(rename-file (string-append out "/share/man/man3")
- (string-append doc "/share/man/man3"))
- #t)))
+ (string-append doc "/share/man/man3")))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(substitute* "tests/runtests.pl"