summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-09 22:43:36 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-09 23:29:50 +0200
commit5625adfcccf1bcd81a1948650c1d8fd53eb789dc (patch)
treed058dc289122673f8731938c30d69e18298df241 /gnu/packages/curl.scm
parenteb55e28c84988abe15b6675a403fa07b75cbf209 (diff)
downloadguix-patches-5625adfcccf1bcd81a1948650c1d8fd53eb789dc.tar
guix-patches-5625adfcccf1bcd81a1948650c1d8fd53eb789dc.tar.gz
gnu: curl: Use 'modify-phases'.
* gnu/packages/curl.scm (curl)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm64
1 files changed, 32 insertions, 32 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index 4523d529e7..55a5d1e782 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -63,40 +63,40 @@
`(#:configure-flags '("--with-gnutls" "--with-gssapi")
;; Add a phase to patch '/bin/sh' occurances in tests/runtests.pl
#:phases
- (alist-replace
- 'check
- (lambda _
- (substitute* "tests/runtests.pl"
- (("/bin/sh") (which "sh")))
- ;; Test #1135 requires extern-scan.pl, which is not part of the
- ;; tarball due to a mistake. It has been fixed upstream. We can
- ;; simply disable the test as it is specific to VMS and OS/400.
- (delete-file "tests/data/test1135")
+ (modify-phases %standard-phases
+ (replace
+ 'check
+ (lambda _
+ (substitute* "tests/runtests.pl"
+ (("/bin/sh") (which "sh")))
+ ;; Test #1135 requires extern-scan.pl, which is not part of the
+ ;; tarball due to a mistake. It has been fixed upstream. We can
+ ;; simply disable the test as it is specific to VMS and OS/400.
+ (delete-file "tests/data/test1135")
- ;; XXX FIXME: Test #1510 seems to work on some machines and not
- ;; others, possibly based on the kernel version. It works on GuixSD
- ;; on x86_64 with linux-libre-4.1, but fails on Hydra for both i686
- ;; and x86_64 with the following error:
- ;;
- ;; test 1510...[HTTP GET connection cache limit (CURLOPT_MAXCONNECTS)]
- ;;
- ;; 1510: output (log/stderr1510) FAILED:
- ;; --- log/check-expected 2015-06-27 07:45:53.166720834 +0000
- ;; +++ log/check-generated 2015-06-27 07:45:53.166720834 +0000
- ;; @@ -1,5 +1,5 @@
- ;; * Connection #0 to host server1.example.com left intact[LF]
- ;; * Connection #1 to host server2.example.com left intact[LF]
- ;; * Connection #2 to host server3.example.com left intact[LF]
- ;; -* Closing connection 0[LF]
- ;; +* Closing connection 1[LF]
- ;; * Connection #3 to host server4.example.com left intact[LF]
- (delete-file "tests/data/test1510")
+ ;; XXX FIXME: Test #1510 seems to work on some machines and not
+ ;; others, possibly based on the kernel version. It works on GuixSD
+ ;; on x86_64 with linux-libre-4.1, but fails on Hydra for both i686
+ ;; and x86_64 with the following error:
+ ;;
+ ;; test 1510...[HTTP GET connection cache limit (CURLOPT_MAXCONNECTS)]
+ ;;
+ ;; 1510: output (log/stderr1510) FAILED:
+ ;; --- log/check-expected 2015-06-27 07:45:53.166720834 +0000
+ ;; +++ log/check-generated 2015-06-27 07:45:53.166720834 +0000
+ ;; @@ -1,5 +1,5 @@
+ ;; * Connection #0 to host server1.example.com left intact[LF]
+ ;; * Connection #1 to host server2.example.com left intact[LF]
+ ;; * Connection #2 to host server3.example.com left intact[LF]
+ ;; -* Closing connection 0[LF]
+ ;; +* Closing connection 1[LF]
+ ;; * Connection #3 to host server4.example.com left intact[LF]
+ (delete-file "tests/data/test1510")
- ;; The top-level "make check" does "make -C tests quiet-test", which
- ;; is too quiet. Use the "test" target instead, which is more
- ;; verbose.
- (zero? (system* "make" "-C" "tests" "test")))
- %standard-phases)))
+ ;; The top-level "make check" does "make -C tests quiet-test", which
+ ;; is too quiet. Use the "test" target instead, which is more
+ ;; verbose.
+ (zero? (system* "make" "-C" "tests" "test")))))))
(synopsis "Command line tool for transferring data with URL syntax")
(description
"curl is a command line tool for transferring data with URL syntax,