summaryrefslogtreecommitdiff
path: root/gnu/packages/curl.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-08-25 16:59:32 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-08-31 15:52:33 +0200
commit3b2d3f10868c57fe0b5641dfd9d37276b9ea6b3f (patch)
treeaf5b93fbd9ee15d35904416bcb7cabfc18251e12 /gnu/packages/curl.scm
parentcb68d199d0f50e030fcb9d616ef73b3c0da722e0 (diff)
downloadguix-patches-3b2d3f10868c57fe0b5641dfd9d37276b9ea6b3f.tar
guix-patches-3b2d3f10868c57fe0b5641dfd9d37276b9ea6b3f.tar.gz
gnu: Add h2c.
* gnu/packages/curl.scm (h2c): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/curl.scm')
-rw-r--r--gnu/packages/curl.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/curl.scm b/gnu/packages/curl.scm
index e6f1bb0c41..c61a56256c 100644
--- a/gnu/packages/curl.scm
+++ b/gnu/packages/curl.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Dale Mellor <guix-devel-0brg6b@rdmp.org>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
+;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system go)
#:use-module (gnu packages)
@@ -334,3 +336,30 @@ user+password authentication, file transfer resume, http proxy tunneling and
more!")
(home-page "http://www.curlpp.org")
(license license:expat)))
+
+(define-public h2c
+ (package
+ (name "h2c")
+ (version "1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/curl/h2c")
+ (commit version)))
+ (sha256
+ (base32
+ "1n8z6avzhg3yb330di2y9zymsps1qp1235p29kidcp4fkmn7fgb2"))
+ (file-name (git-file-name name version))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("./h2c" "bin/"))))
+ (inputs
+ `(("perl" ,perl)))
+ (home-page "https://curl.se/h2c/")
+ (synopsis "Convert HTTP headers to a curl command line")
+ (description
+ "Provided a set of HTTP request headers, h2c outputs how to invoke
+curl to obtain exactly that HTTP request.")
+ (license license:expat)))