summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-18 23:52:17 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-19 22:16:18 +0100
commitaa954ec3664738f3d7b75a5ba96f787b93ad50c8 (patch)
treea8f5d46462bc81cc2c81e2721645650b5cf0989f /gnu/packages/cups.scm
parent92797b3b8888140086c6ab5bb30b2d4570484ce3 (diff)
downloadguix-patches-aa954ec3664738f3d7b75a5ba96f787b93ad50c8.tar
guix-patches-aa954ec3664738f3d7b75a5ba96f787b93ad50c8.tar.gz
gnu: escpr: Compress PPDs.
* gnu/packages/cups.scm (escpr)[arguments]: Import SRFI-26 and add a ‘compress-PPDs’ phase.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index d1d6978758..1e25d545b2 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -762,7 +762,10 @@ HP@tie{}LaserJet, and possibly other printers. See @file{README} for details.")
(base32 "1pygg2bd2gh27dc65h3dzwrpvi6bq5c87wl0ldchqlc2b3blsx6p"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags
+ `(#:modules
+ ((srfi srfi-26)
+ ,@%gnu-build-system-modules)
+ #:configure-flags
`(,(string-append "--prefix="
(assoc-ref %outputs "out"))
,(string-append "--with-cupsfilterdir="
@@ -781,7 +784,13 @@ HP@tie{}LaserJet, and possibly other printers. See @file{README} for details.")
(string-append match "aclocal"))
(("^(AUTOMAKE=).*" _ match)
(string-append match "automake")))
- #t)))))
+ #t))
+ (add-after 'install 'compress-PPDs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (with-directory-excursion out
+ (for-each (cut invoke "gzip" "-9" <>)
+ (find-files "share/cups" "\\.ppd$")))))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)))