summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-04 13:35:46 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-04 14:35:18 +0200
commita2f25137241859f03e980a8e2452c1cb4db9fe43 (patch)
tree7103104fb5988efe0bdbfa82da02e70ba5e27971 /gnu/packages/cups.scm
parent85c84b1071b0886c70abb510c80b825f5335ed84 (diff)
downloadguix-patches-a2f25137241859f03e980a8e2452c1cb4db9fe43.tar
guix-patches-a2f25137241859f03e980a8e2452c1cb4db9fe43.tar.gz
gnu: hplip: Update to 3.20.9 [security fixes].
* gnu/packages/cups.scm (hplip): Update to 3.20.9. [source]: Add hplip-fix-bug-1898438.patch. [arguments]: Follow upstream defaults. * gnu/packages/patches/hplip-fix-bug-1898438.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index d12247f7f3..173f8ca0f5 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -415,16 +415,17 @@ should only be used as part of the Guix cups-pk-helper service.")
(define-public hplip
(package
(name "hplip")
- (version "3.20.6")
+ (version "3.20.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
- "083w58wpvvm6sir6rf5dwx3r0rman9sv1zpl26chl0a88crjsjy6"))
+ "1prdbp410405xrfggjc7y34nzljg7jnbgjzalgv4khwwma4i299n"))
(modules '((guix build utils)))
- (patches (search-patches "hplip-remove-imageprocessor.patch"))
+ (patches (search-patches "hplip-fix-bug-1898438.patch"
+ "hplip-remove-imageprocessor.patch"))
(snippet
'(begin
;; Delete non-free blobs: .so files, pre-compiled
@@ -465,10 +466,7 @@ should only be used as part of the Guix cups-pk-helper service.")
(assoc-ref %outputs "out") "/lib")
;; Disable until mime.types merging works (FIXME).
"--disable-fax-build"
- "--enable-hpcups-install"
"--enable-new-hpcups"
- "--enable-cups_ppd_install"
- "--enable-cups_drv_install"
;; TODO add foomatic drv install eventually.
;; TODO --enable-policykit eventually.
,(string-append "--with-cupsfilterdir="