summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-18 02:33:42 -0400
committerMark H Weaver <mhw@netris.org>2018-03-18 23:30:01 -0400
commit74c164e000e8f064a1c38e8e7960b990c428af6a (patch)
treef54174e946c1d16037f4badf9089f3571ecf211c /gnu/packages/cups.scm
parente923cee1b9b01ba9f616aec41678a908927111b6 (diff)
downloadguix-patches-74c164e000e8f064a1c38e8e7960b990c428af6a.tar
guix-patches-74c164e000e8f064a1c38e8e7960b990c428af6a.tar.gz
gnu: cups: Return #t from all phases.
* gnu/packages/cups.scm (cups, cups-minimal): Return #t from all phases.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm22
1 files changed, 15 insertions, 7 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 209f8da3d2..741f97adf3 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -198,7 +198,8 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
(lambda _
(substitute* "Makedefs.in"
(("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
- (("/bin/sh") (which "sh")))))
+ (("/bin/sh") (which "sh")))
+ #t))
;; Make the compressed manpages writable so that the
;; reset-gzip-timestamps phase does not error out.
(add-before 'reset-gzip-timestamps 'make-manpages-writable
@@ -206,12 +207,14 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
(let* ((out (assoc-ref outputs "out"))
(man (string-append out "/share/man")))
(for-each (lambda (file) (chmod file #o644))
- (find-files man "\\.gz")))))
+ (find-files man "\\.gz"))
+ #t)))
(add-before 'build 'patch-tests
(lambda _
(substitute* "test/ippserver.c"
(("# else /\\* HAVE_AVAHI \\*/")
- "#elif defined(HAVE_AVAHI)")))))))
+ "#elif defined(HAVE_AVAHI)"))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs
@@ -249,7 +252,8 @@ device-specific programs to convert and print many types of files.")
(lambda _
(substitute* "Makedefs.in"
(("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
- (("/bin/sh") (which "sh")))))
+ (("/bin/sh") (which "sh")))
+ #t))
(add-before 'check 'patch-tests
(lambda _
(let ((filters (assoc-ref %build-inputs "cups-filters"))
@@ -307,7 +311,8 @@ device-specific programs to convert and print many types of files.")
(("cupsFileFind\\(\"cat\", \"/bin\"")
(string-append "cupsFileFind(\"cat\", \"" catpath "\""))
(("cupsFileFind\\(\"cat\", \"/bin:/usr/bin\"")
- (string-append "cupsFileFind(\"cat\", \"" catpath "\""))))))
+ (string-append "cupsFileFind(\"cat\", \"" catpath "\"")))
+ #t)))
;; Make the compressed manpages writable so that the
;; reset-gzip-timestamps phase does not error out.
(add-before 'reset-gzip-timestamps 'make-manpages-writable
@@ -315,7 +320,8 @@ device-specific programs to convert and print many types of files.")
(let* ((out (assoc-ref outputs "out"))
(man (string-append out "/share/man")))
(for-each (lambda (file) (chmod file #o644))
- (find-files man "\\.gz")))))
+ (find-files man "\\.gz"))
+ #t)))
(add-after 'install 'install-cups-filters-symlinks
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -361,7 +367,9 @@ device-specific programs to convert and print many types of files.")
(let ((data "/share/cups/data"))
(delete-file-recursively (string-append out data))
(symlink (string-append cups-filters data)
- (string-append out data)))))))))
+ (string-append out data)))
+
+ #t))))))
(inputs
`(("avahi" ,avahi)
("gnutls" ,gnutls)