summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-09 12:55:52 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-09 12:55:52 +0200
commit5ba3ea4211931e635209ee1a61b4811071d3773d (patch)
tree0acd0aa1bb667fb724ce262c435431f3ad435def /gnu/packages/cups.scm
parent1e429a82636409f762e20d29e07ce50708832add (diff)
downloadguix-patches-5ba3ea4211931e635209ee1a61b4811071d3773d.tar
guix-patches-5ba3ea4211931e635209ee1a61b4811071d3773d.tar.gz
gnu: CUPS: Update to 2.3.0.
* gnu/packages/cups.scm (cups-minimal): Update to 2.3.0. [arguments]: Adjust for renamed test file. [license]: Change to ASL2.0.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 229e0bb425..4c35c64c6c 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -187,7 +187,7 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
(define-public cups-minimal
(package
(name "cups-minimal")
- (version "2.2.11")
+ (version "2.3.0")
(source
(origin
(method url-fetch)
@@ -195,7 +195,7 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
version "/cups-" version "-source.tar.gz"))
(sha256
(base32
- "0v5p10lyv8wv48s8ghkhjmdrxg6iwj8hn36v1ilkz46n7y0i107m"))))
+ "19d1jpdpxy0fclq37pchi7ldnw9dssxx3zskcgqai3h0rwlh5bxc"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -225,7 +225,7 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
#t)))
(add-before 'build 'patch-tests
(lambda _
- (substitute* "test/ippserver.c"
+ (substitute* "tools/ippeveprinter.c"
(("# else /\\* HAVE_AVAHI \\*/")
"#elif defined(HAVE_AVAHI)"))
#t)))))
@@ -245,7 +245,8 @@ networked printers, and printers can be shared from one computer to another.
Internally, CUPS uses PostScript Printer Description (@dfn{PPD}) files to
describe printer capabilities and features, and a wide variety of generic and
device-specific programs to convert and print many types of files.")
- (license license:gpl2)))
+ ;; CUPS is Apache 2.0 with exceptions, see the NOTICE file.
+ (license license:asl2.0)))
(define-public cups
(package (inherit cups-minimal)