summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-15 22:55:24 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-15 22:55:24 +0200
commit25487c3fe6a41dd62f6e53f256392224a3be2a08 (patch)
tree1051a1716d962ba0a7bbbf9dc8f7b67aa2674400 /gnu/packages/cups.scm
parent4a9597e4516ec5ca58df3e007fcd5ef1d3fd2e54 (diff)
parent46eac03e720e9b21d225e2ec1c41299c09202d18 (diff)
downloadguix-patches-25487c3fe6a41dd62f6e53f256392224a3be2a08.tar
guix-patches-25487c3fe6a41dd62f6e53f256392224a3be2a08.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 2ae3e5e0fd..bbeb565657 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -487,16 +487,15 @@ should only be used as part of the Guix cups-pk-helper service.")
(define-public hplip
(package
(name "hplip")
- (version "3.21.2")
+ (version "3.21.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
- "0hbwx9d4c8177vi0gavz9pxi7rc97jciacndp90ms8327shj2121"))
+ "1lsa0g8lafnmfyia0vy9x1j9q2l80xjjm7clkrawrbg53y3x7ixx"))
(modules '((guix build utils)))
- (patches (search-patches "hplip-remove-imageprocessor.patch"))
(snippet
'(begin
;; Delete non-free blobs: .so files, pre-compiled
@@ -505,7 +504,14 @@ should only be used as part of the Guix cups-pk-helper service.")
(find-files "."
(lambda (file stat)
(elf-file? file))))
+
+ ;; Now remove some broken references to them.
(delete-file "prnt/hpcups/ImageProcessor.h")
+ (substitute* "Makefile.in"
+ ((" -lImageProcessor ") " ")
+ (("(\\@HPLIP_BUILD_TRUE\\@[[:blank:]]*).*libImageProcessor.*"
+ _ prefix)
+ (string-append prefix ":; \\\n")))
;; Install binaries under libexec/hplip instead of
;; share/hplip; that'll at least ensure they get stripped.
@@ -530,7 +536,8 @@ should only be used as part of the Guix cups-pk-helper service.")
;; TODO install apparmor profile files eventually.
(arguments
`(#:configure-flags
- `("--disable-network-build"
+ `("--disable-imageProcessor-build"
+ "--disable-network-build"
,(string-append "--prefix=" (assoc-ref %outputs "out"))
,(string-append "--sysconfdir=" (assoc-ref %outputs "out") "/etc")
,(string-append "LDFLAGS=-Wl,-rpath="