summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-11-08 09:06:14 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-11-08 09:06:14 +0200
commit1c94392a13cbdf87e03a644633eb775bf45694a1 (patch)
tree74f11038dfc5f9d9db06660b1087253b28c5434f /gnu/packages/cups.scm
parentdd87bbb2b78b279248aaff15c0706fcd6d8cd7bb (diff)
parent9d25ee30b188f9202cc14f7cd25ba8a1c3ec1a72 (diff)
downloadguix-patches-1c94392a13cbdf87e03a644633eb775bf45694a1.tar
guix-patches-1c94392a13cbdf87e03a644633eb775bf45694a1.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index cb9a36b962..bf92905f9c 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -502,14 +502,14 @@ should only be used as part of the Guix cups-pk-helper service.")
(define-public hplip
(package
(name "hplip")
- (version "3.21.8")
+ (version "3.21.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
- "076fjzgw86q817c660h1vzwdp00cyjr49b9bfi7qkhphq6am4gpi"))
+ "0q3adcp8iygravp4bq4gw14jk20c5rhnawj1333qyw8yvlghw8yy"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -524,9 +524,13 @@ should only be used as part of the Guix cups-pk-helper service.")
(delete-file "prnt/hpcups/ImageProcessor.h")
(substitute* "Makefile.in"
((" -lImageProcessor ") " ")
- (("(\\@HPLIP_BUILD_TRUE\\@[[:blank:]]*).*libImageProcessor.*"
+ ;; Turn shell commands inside an if…fi into harmless no-ops.
+ (("^(\\@HPLIP_BUILD_TRUE\\@[[:blank:]]*).*libImageProcessor.*"
_ prefix)
- (string-append prefix ":; \\\n")))
+ (string-append prefix ": ; \\\n"))
+ ;; Remove the lines adding file targets altogether.
+ (("^\\@FULL_BUILD_TRUE\\@.*libImageProcessor.*")
+ ""))
;; Install binaries under libexec/hplip instead of
;; share/hplip; that'll at least ensure they get stripped.