summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-01-29 10:02:21 +0000
committerChristopher Baines <mail@cbaines.net>2019-02-13 08:18:59 +0000
commit12255b3dceec29f9d022386507bbc157af7ef840 (patch)
tree530640d11a33c689b0a6dc3e6615813e42b2f73f /gnu/packages/cups.scm
parente7e259a50335269cddd004482a655f59d5c7a237 (diff)
downloadguix-patches-12255b3dceec29f9d022386507bbc157af7ef840.tar
guix-patches-12255b3dceec29f9d022386507bbc157af7ef840.tar.gz
gnu: Add cups-pk-helper.
* gnu/packages/cups.scm (cups-pk-helper): New variable.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 9c470c4bb6..367f45aa99 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -38,6 +38,7 @@
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
@@ -380,6 +381,32 @@ device-specific programs to convert and print many types of files.")
("cups-filters" ,cups-filters)
("zlib" ,zlib)))))
+(define-public cups-pk-helper
+ (package
+ (name "cups-pk-helper")
+ (version "0.2.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://freedesktop.org/software/"
+ name "/releases/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0a52jw6rm7lr5nbyksiia0rn7sasyb5cjqcb95z1wxm2yprgi6lm"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("glib" ,glib)
+ ("polkit" ,polkit)
+ ("cups" ,cups)))
+ (home-page "https://www.freedesktop.org/wiki/Software/cups-pk-helper/")
+ (synopsis "PolicyKit helper to configure CUPS with fine-grained privileges")
+ (description
+ "This package provides the org.opensuse.CupsPkHelper.Mechanism DBus
+system service which uses @file{cups-pk-helper-mechanism}. This package
+should only be used as part of the Guix cups-pk-helper service.")
+ (license license:gpl2+)))
+
(define-public hplip
(package
(name "hplip")