summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-05-13 15:00:26 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-13 16:50:49 +0200
commit0cbc8357b377be278a675467b05a26f148fad8fb (patch)
tree69386a734dfd1511a029075ee5343e0d11359251 /gnu/packages/cups.scm
parent485a70264db01c37aa66c63994573a3b7d060704 (diff)
downloadguix-patches-0cbc8357b377be278a675467b05a26f148fad8fb.tar
guix-patches-0cbc8357b377be278a675467b05a26f148fad8fb.tar.gz
gnu: hplip: Update to 3.21.4.
* gnu/packages/cups.scm (hplip): Update to 3.21.4. [source]: Remove fussy patch. Replace it with an short snippet substitution and... [arguments]: ...the new "--disable-imageProcessor-build" configure flag. * gnu/packages/patches/hplip-remove-imageprocessor.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 1321148ba0..ee05d2885b 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -484,16 +484,15 @@ should only be used as part of the Guix cups-pk-helper service.")
(define-public hplip
(package
(name "hplip")
- (version "3.21.2")
+ (version "3.21.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
- "0hbwx9d4c8177vi0gavz9pxi7rc97jciacndp90ms8327shj2121"))
+ "1lsa0g8lafnmfyia0vy9x1j9q2l80xjjm7clkrawrbg53y3x7ixx"))
(modules '((guix build utils)))
- (patches (search-patches "hplip-remove-imageprocessor.patch"))
(snippet
'(begin
;; Delete non-free blobs: .so files, pre-compiled
@@ -502,7 +501,14 @@ should only be used as part of the Guix cups-pk-helper service.")
(find-files "."
(lambda (file stat)
(elf-file? file))))
+
+ ;; Now remove some broken references to them.
(delete-file "prnt/hpcups/ImageProcessor.h")
+ (substitute* "Makefile.in"
+ ((" -lImageProcessor ") " ")
+ (("(\\@HPLIP_BUILD_TRUE\\@[[:blank:]]*).*libImageProcessor.*"
+ _ prefix)
+ (string-append prefix ":; \\\n")))
;; Install binaries under libexec/hplip instead of
;; share/hplip; that'll at least ensure they get stripped.
@@ -528,7 +534,8 @@ should only be used as part of the Guix cups-pk-helper service.")
;; TODO install apparmor profile files eventually.
(arguments
`(#:configure-flags
- `("--disable-network-build"
+ `("--disable-imageProcessor-build"
+ "--disable-network-build"
,(string-append "--prefix=" (assoc-ref %outputs "out"))
,(string-append "--sysconfdir=" (assoc-ref %outputs "out") "/etc")
,(string-append "LDFLAGS=-Wl,-rpath="