summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-09-01 02:58:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-09-01 18:27:01 +0200
commit08e46d8d05d2d54c18f3879b1be75c5a122b98b8 (patch)
tree3dfd8bd92e42ad6a5b65eac6d4c6c7a5dce4cb68 /gnu/packages/cups.scm
parent8cb2f0ff2bce0cef922871d21b25779626c2eabf (diff)
downloadguix-patches-08e46d8d05d2d54c18f3879b1be75c5a122b98b8.tar
guix-patches-08e46d8d05d2d54c18f3879b1be75c5a122b98b8.tar.gz
gnu: hplip: Update to 3.19.8.
* gnu/packages/cups.scm (hplip): Update to 3.19.8. [arguments]: Remove type mismatch fix.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 4ce13ae8f8..4be1eee156 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -419,14 +419,14 @@ should only be used as part of the Guix cups-pk-helper service.")
(define-public hplip
(package
(name "hplip")
- (version "3.18.9")
+ (version "3.19.8")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/hplip/hplip/" version
"/hplip-" version ".tar.gz"))
(sha256
(base32
- "0g3q5mm2crjyc1z4z6gv4lam6sc5d3diz704djrnpqadk4q3h290"))
+ "0cmshi5dkmc1n5yiahhp0cv5p94zg61018piiqa2sna10ahgx1d3"))
(modules '((guix build utils)))
(patches (search-patches "hplip-remove-imageprocessor.patch"))
(snippet
@@ -439,10 +439,6 @@ should only be used as part of the Guix cups-pk-helper service.")
(elf-file? file))))
(delete-file "prnt/hpcups/ImageProcessor.h")
- ;; Fix type mismatch.
- (substitute* "prnt/hpcups/genPCLm.cpp"
- (("boolean") "bool"))
-
;; Install binaries under libexec/hplip instead of
;; share/hplip; that'll at least ensure they get stripped.
;; It's not even clear that they're of any use though...