summaryrefslogtreecommitdiff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorDiego Nicola Barbato <dnbarbato@posteo.de>2017-11-01 02:48:14 +0100
committerLudovic Courtès <ludo@gnu.org>2017-11-10 13:07:54 +0100
commit011f57695a817f9b13c75e43069e572101a3edf7 (patch)
tree545ec84ae5d75517eeb8c184d6d2d9d16aa777f1 /gnu/packages/cups.scm
parent195f0d05c3f64e17e84b2683a7045a14ec578d61 (diff)
downloadguix-patches-011f57695a817f9b13c75e43069e572101a3edf7.tar
guix-patches-011f57695a817f9b13c75e43069e572101a3edf7.tar.gz
gnu: Add Epson escpr printer driver.
* gnu/packages/cups.scm (escpr): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 491668e522..bbf2699f00 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -599,3 +599,39 @@ printer/driver specific, but spooler-independent PPD file.")
protocols, which cover printers made by Konica, HP (LaserJet), Oki, Samsung,
and more. See @file{README} for details.")
(license license:gpl2+)))
+
+(define-public escpr
+ (package
+ (name "escpr")
+ (version "1.6.17")
+ ;; XXX: This currently works. But it will break as soon as a newer
+ ;; version is available since the URLs for older versions are not
+ ;; preserved. An alternative source will be added as soon as
+ ;; available.
+ (source (origin
+ (method url-fetch)
+ ;; The uri has to be chopped up in order to satisfy guix lint.
+ (uri (string-append "https://download3.ebz.epson.net/dsc/f/03/00/06/66/09/"
+ "4ac2bf69bb1ddf4a9ad525596615cbb40fe4dad5/"
+ "epson-inkjet-printer-escpr-1.6.17-1lsb3.2.tar.gz"))
+ (sha256
+ (base32
+ "0m6v1wdavw4r25jfywqchsx0v9ss1l5fr8vq9d0d8cmjnz8mqblv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ `(,(string-append "--prefix="
+ (assoc-ref %outputs "out"))
+ ,(string-append "--with-cupsfilterdir="
+ (assoc-ref %outputs "out") "/lib/cups/filter")
+ ,(string-append "--with-cupsppddir="
+ (assoc-ref %outputs "out") "/share/ppd"))))
+ (inputs `(("cups" ,cups-minimal)))
+ (synopsis "ESC/P-R printer driver")
+ (description
+ "This package provides a filter for the Common UNIX Printing
+System (CUPS). It offers high-quality printing with Seiko Epson color ink jet
+printers. It can only be used with printers that support the Epson ESC/P-R
+language.")
+ (home-page "http://download.ebz.epson.net/dsc/search/01/search")
+ (license license:gpl2+)))