summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2021-05-21 15:40:39 -0400
committerLeo Famulari <leo@famulari.name>2021-05-27 13:55:24 -0400
commitd1b3b5b73da9a87991246ec40f6fd64e70b4e33a (patch)
tree9d6da15e6ca4246e5eb6840a7d312cb16a363b35 /gnu/packages/crypto.scm
parent5f1c4692a551abed8139f701d91611c85cd63607 (diff)
downloadguix-patches-d1b3b5b73da9a87991246ec40f6fd64e70b4e33a.tar
guix-patches-d1b3b5b73da9a87991246ec40f6fd64e70b4e33a.tar.gz
gnu: botan: Respect #:tests?.
* gnu/packages/crypto.scm (botan)[arguments]: Respect #:tests? in the custom 'check' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index f333aced1b..674cb05801 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -976,7 +976,9 @@ SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R
(add-before 'check 'library-path-for-tests
(lambda _ (setenv "LD_LIBRARY_PATH" (getcwd))))
(replace 'check
- (lambda _ (invoke "./botan-test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (if tests?
+ (invoke "./botan-test")))))))
(native-inputs
`(("python" ,python-wrapper)
("python-docutils" ,python-docutils)))