summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-09 00:28:25 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-09 00:54:14 +0100
commitbe4f2d9451344701599b6dc000c0345ce53b2128 (patch)
tree9594a5153222c39eb2e751f5925c6a33b178a81f /gnu/packages/crypto.scm
parent69ad8d92e6e06b88e60aa18f6c3fe6d487460600 (diff)
downloadguix-patches-be4f2d9451344701599b6dc000c0345ce53b2128.tar
guix-patches-be4f2d9451344701599b6dc000c0345ce53b2128.tar.gz
gnu: botan: Use getentropy().
* gnu/packages/crypto.scm (botan)[arguments]: Enable the ‘getentropy’ OS feature.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index c3d3e3658c..1f5bfc1631 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -757,7 +757,10 @@ SHA256, SHA512, SHA3, AICH, ED2K, Tiger, DC++ TTH, BitTorrent BTIH, GOST R
;; Otherwise, the `botan` executable cannot find
;; libbotan.
(string-append "--ldflags=-Wl,-rpath=" lib)
+
+ "--with-os-feature=getentropy"
"--with-rst2man"
+
;; Recommended by upstream
"--with-zlib" "--with-bzip2" "--with-sqlite3"))))
(replace 'check