summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2019-12-08 12:27:31 +0100
committerEfraim Flashner <efraim@flashner.co.il>2019-12-11 04:51:57 +0200
commitbc587eb178799ccb9bd051f8f46569e1673a9991 (patch)
tree18babd7935629091fb71a6f6728f38208e6f01ee /gnu/packages/crypto.scm
parent27f8d98f8e5608ebb0a466fd8d19f3bcb860263f (diff)
downloadguix-patches-bc587eb178799ccb9bd051f8f46569e1673a9991.tar
guix-patches-bc587eb178799ccb9bd051f8f46569e1673a9991.tar.gz
gnu: enchive: Update to 3.5.
* gnu/packages/crypto.scm (enchive): Update to 3.5. [source]: Replace url-fetch with git-fetch. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 80c598ed86..e63823de2c 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -852,15 +852,16 @@ cannot sign messages in OpenBSD format yet.")
(define-public enchive
(package
(name "enchive")
- (version "3.4")
+ (version "3.5")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/skeeto/" name "/archive/"
- version ".tar.gz"))
- (sha256
- (base32
- "17hrxpp4cpn10bk48sfvfjc8hghky34agsnypam1v9f36kbalqfk"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/skeeto/enchive")
+ (commit version)))
+ (sha256
+ (base32
+ "0fdrfc5l42lj2bvmv9dmkmhmm7qiszwk7cmdvnqad3fs7652g0qa"))
+ (file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no check target '