summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-16 04:06:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-16 04:11:45 +0100
commitb0ff82461c81560eb7e215c4a435a2dd4882e6bb (patch)
tree04ef09a97e675a95c0478eb31df451da9a79dd3c /gnu/packages/crypto.scm
parent675c520c40b5223bfa0ec851be110f257ba8704d (diff)
downloadguix-patches-b0ff82461c81560eb7e215c4a435a2dd4882e6bb.tar
guix-patches-b0ff82461c81560eb7e215c4a435a2dd4882e6bb.tar.gz
gnu: libolm: Fix (run) the tests.
* gnu/packages/crypto.scm (libolm)[arguments]: Invoke ctest from within the right directory.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index c5aa1f53f9..aa6f80f731 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1240,13 +1240,14 @@ Trusted comments are signed, thus verified, before being displayed.")
(base32
"14b5cplcnbf2baq0lvz4f97m6swxpb13rvxdajxyw3s4mbvasia4"))
(file-name (git-file-name name version))))
+ (build-system cmake-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
- (invoke "ctest" "build/tests"))))))
- (build-system cmake-build-system)
+ (with-directory-excursion "tests"
+ (invoke "ctest" ".")))))))
(synopsis "Implementation of the olm and megolm cryptographic ratchets")
(description "The libolm library implements the Double Ratchet
cryptographic ratchet. It is written in C and C++11, and exposed as a C