summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-24 23:12:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-25 13:21:18 +0100
commit8543ccf87b9a8664fd02d595e8015c62d0f6841d (patch)
tree076c687286b098f97787c3900fe28d93ed385734 /gnu/packages/crypto.scm
parente60b3e14a1b4a35ab7d8afb3da85ad59b44ee367 (diff)
downloadguix-patches-8543ccf87b9a8664fd02d595e8015c62d0f6841d.tar
guix-patches-8543ccf87b9a8664fd02d595e8015c62d0f6841d.tar.gz
gnu: eschalot: Use INVOKE.
* gnu/packages/crypto.scm (eschalot)[arguments]: Unconditionally return #T from check phase.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 2c63e53191..bef8235a97 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 David Thompson <davet@gnu.org>
-;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox>
;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -303,13 +303,12 @@ secure operations. ")
(delete 'configure)
(replace 'check
(lambda _
- (and
- (zero? (system* "./worgen" "8-12" "top1000.txt" "3-10" "top400nouns.txt"
- "3-6" "top150adjectives.txt" "3-6"))
- (zero? (system* "./eschalot" "-r" "^guix|^guixsd"))
- (zero? (system* "./eschalot" "-r" "^gnu|^free"))
- (zero? (system* "./eschalot" "-r" "^cyber|^hack"))
- (zero? (system* "./eschalot" "-r" "^troll")))))
+ (invoke "./worgen" "8-12" "top1000.txt" "3-10" "top400nouns.txt"
+ "3-6" "top150adjectives.txt" "3-6")
+ (invoke "./eschalot" "-r" "^guix|^guixsd")
+ (invoke "./eschalot" "-r" "^gnu|^free")
+ (invoke "./eschalot" "-r" "^cyber|^hack")
+ (invoke "./eschalot" "-r" "^troll")))
;; Make install can not create the bin dir, create it.
(add-before 'install 'create-bin-dir
(lambda* (#:key outputs #:allow-other-keys)