summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-30 21:09:59 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-04-30 21:36:10 +0200
commit53bed20918db76e021d39d6b82ac95a095893298 (patch)
tree9b5497b4294b429c00a6d69edfd54fc050d1c418 /gnu/packages/crypto.scm
parent539a8d29319de87b85eb8919346063e5d0bb0f5c (diff)
downloadguix-patches-53bed20918db76e021d39d6b82ac95a095893298.tar
guix-patches-53bed20918db76e021d39d6b82ac95a095893298.tar.gz
gnu: rhash: Update to 1.3.6.
* gnu/packages/crypto.scm (rhash): Update to 1.3.6. [arguments]: Adjust to extensive build system changes.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm33
1 files changed, 14 insertions, 19 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 9a786def32..f96fe04900 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -671,7 +671,7 @@ BLAKE.")
(define-public rhash
(package
(name "rhash")
- (version "1.3.5")
+ (version "1.3.6")
(source
(origin
(method url-fetch)
@@ -680,32 +680,27 @@ BLAKE.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0bhz3xdl6r06k1bqigdjz42l31iqz2qdpg7zk316i7p2ra56iq4q"))))
+ "14ngzfgmd1lfp7m78sn49x8ymf2s37nrr67c6p5vas85nrrgjkcn"))))
(build-system gnu-build-system)
(arguments
- `(#:make-flags (list "CC=gcc"
- (string-append "PREFIX=" %output))
- #:test-target "test"
+ `(#:make-flags
+ ;; The binaries in /bin need some help finding librhash.so.0.
+ (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+ #:test-target "test" ; ‘make check’ just checks the sources
#:phases
(modify-phases %standard-phases
(replace 'configure
+ ;; ./configure is not GNU autotools' and doesn't gracefully handle
+ ;; unrecognized options, so we must call it manually.
(lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("\\$\\(DESTDIR\\)/etc")
- (string-append (assoc-ref outputs "out") "/etc")))
- #t))
- (add-after 'build 'build-library
+ (invoke "./configure"
+ (string-append "--prefix=" (assoc-ref outputs "out")))))
+ (add-after 'install 'install-library-extras
(lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "lib-shared" make-flags)))
- (add-after 'install 'install-library
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "install-lib-shared" make-flags)
(apply invoke
- "make" "-C" "librhash" "install-headers"
- "install-so-link" make-flags)))
- (add-after 'check 'check-library
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "test-shared-lib" make-flags))))))
+ "make" "-C" "librhash"
+ "install-headers" "install-so-link"
+ make-flags))))))
(home-page "https://sourceforge.net/projects/rhash/")
(synopsis "Utility for computing hash sums")
(description "RHash is a console utility for calculation and verification