summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-10-14 00:28:21 -0400
committerLeo Famulari <leo@famulari.name>2021-10-26 12:06:26 -0400
commit3d51fd19faee59d9455eebbb957cf6498ecc1220 (patch)
treea48850c6a7b4ed901f4336e6405a27aae92fb572 /gnu/packages/crypto.scm
parent0a42998a50e8bbe9e49142b21a570db00efe7491 (diff)
downloadguix-patches-3d51fd19faee59d9455eebbb957cf6498ecc1220.tar
guix-patches-3d51fd19faee59d9455eebbb957cf6498ecc1220.tar.gz
gnu: Add b2sum.
* gnu/packages/crypto.scm (b2sum): New variable.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm37
1 files changed, 36 insertions, 1 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 823b888b82..209375f44e 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2016, 2017, 2018, 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2017, 2018, 2019, 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox>
;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
@@ -840,6 +840,41 @@ as the latest standard, SHA-3. It is an improved version of the SHA-3 finalist
BLAKE.")
(license license:public-domain)))
+(define-public b2sum
+ ;; Upstream doesn't seem to use a versioned release workflow, so build from
+ ;; a recent commit.
+ (let ((commit "54f4faa4c16ea34bcd59d16e8da46a64b259fc07")
+ (revision "0"))
+ (package
+ (name "b2sum")
+ (version (git-version "20190724" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BLAKE2/BLAKE2")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04z631v0vzl52g73v390ask5fnzi5wg83lcjkjhpmmymaz0jn152"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:tests? #f ; No test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'change-directory
+ (lambda _
+ (chdir "b2sum")))
+ (delete 'configure)))) ; No ./configure script
+ (home-page "https://www.blake2.net/")
+ (synopsis "BLAKE2 checksum tool")
+ (description "BLAKE2 is a cryptographic hash function faster than MD5,
+SHA-1, SHA-2, and SHA-3, yet is at least as secure as SHA-3.")
+ ;; You may also choose to redistribute this program as Apache 2.0 or the
+ ;; OpenSSL license. See 'b2sum/b2sum.c' in the source distribution.
+ (license license:cc0))))
+
(define-public rhash
(package
(name "rhash")