summaryrefslogtreecommitdiff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-18 14:18:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-18 14:35:57 +0200
commit1df9245586939e5a359f8c486662642d9d5998b5 (patch)
tree9cc4950925b88845de3d72a1eb9bb268c89e65af /gnu/packages/crypto.scm
parent4ad2c9db7da7591da098954cc475818f7eb97c26 (diff)
downloadguix-patches-1df9245586939e5a359f8c486662642d9d5998b5.tar
guix-patches-1df9245586939e5a359f8c486662642d9d5998b5.tar.gz
gnu: encfs: Fix build failure with GCC 7.
Fixes <https://bugs.gnu.org/37779>. Reported by Pierre Neidhardt <mail@ambrevar.xyz>. * gnu/packages/crypto.scm (encfs)[arguments]: Add phase 'patch-CMakeLists.txt'.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index e8cf8157d5..a8f60f1665 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -211,6 +211,15 @@ OpenBSD tool of the same name.")
(copy-recursively (assoc-ref inputs "googletest-source")
"vendor/github.com/google/googletest")
#t))
+ (add-before 'configure 'patch-CMakeLists.txt
+ (lambda _
+ ;; Prevent CMake from adding libc on the system include path.
+ ;; Otherwise it will interfere with the libc used by GCC and
+ ;; ultimately cause #include_next errors.
+ (substitute* "CMakeLists.txt"
+ (("include_directories \\(SYSTEM \\$\\{Intl_INCLUDE_DIRS\\}\\)")
+ ""))
+ #t))
(add-before 'check 'make-unittests
(lambda _
(invoke "make" "unittests"))))))