summaryrefslogtreecommitdiff
path: root/gnu/packages/cross-base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-11-04 15:16:11 +0100
committerLudovic Courtès <ludo@gnu.org>2016-11-04 15:36:00 +0100
commitfb77c61422ae2d03c0bf655d96b0e88f5f8001da (patch)
tree7471194396b89ba96dd3ca7dfdd63b87c8e66db7 /gnu/packages/cross-base.scm
parent8af47ef603aeea6efbcfe9ab2c4adefefad2f6fb (diff)
downloadguix-patches-fb77c61422ae2d03c0bf655d96b0e88f5f8001da.tar
guix-patches-fb77c61422ae2d03c0bf655d96b0e88f5f8001da.tar.gz
gnu: Remove '%final-inputs' references at the top level.
Due to circular dependencies, referring to bindings exported by other modules from the top level is frowned upon. This patch addresses one of the remaining cases. * gnu/packages/base.scm (%final-inputs): New procedure. * gnu/packages/cross-base.scm: Remove (gnu packages commencement) import. (cross-gcc): Use the new '%final-inputs'. * gnu/packages/make-bootstrap.scm: Remove (gnu packages commencement) import. (package-with-relocatable-glibc): Use the new '%final-inputs'.
Diffstat (limited to 'gnu/packages/cross-base.scm')
-rw-r--r--gnu/packages/cross-base.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 3bd30fd78c..0000a3adcb 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -23,7 +23,6 @@
#:use-module (gnu packages)
#:use-module (gnu packages gcc)
#:use-module (gnu packages base)
- #:use-module (gnu packages commencement)
#:use-module (gnu packages linux)
#:use-module (guix packages)
#:use-module (guix download)
@@ -257,11 +256,11 @@ GCC that does not target a libc; otherwise, target that libc."
;; Call it differently so that the builder can check whether the "libc"
;; input is #f.
- ("libc-native" ,@(assoc-ref %final-inputs "libc"))
+ ("libc-native" ,@(assoc-ref (%final-inputs) "libc"))
;; Remaining inputs.
,@(let ((inputs (append (package-inputs %xgcc)
- (alist-delete "libc" %final-inputs))))
+ (alist-delete "libc" (%final-inputs)))))
(if libc
`(("libc" ,libc)
("xkernel-headers" ;the target headers