summaryrefslogtreecommitdiff
path: root/gnu/packages/cross-base.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-14 19:40:58 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-14 19:40:58 +0100
commit6ee01481c36949680d775af6a125dae2ad4b492d (patch)
treee9a119b826367635990e6b9b15ffa30fd52681c2 /gnu/packages/cross-base.scm
parentdf5188ddfa0c004009c7fcb0ce09a27bb50b9a59 (diff)
downloadguix-patches-6ee01481c36949680d775af6a125dae2ad4b492d.tar
guix-patches-6ee01481c36949680d775af6a125dae2ad4b492d.tar.gz
gnu: Don't build the mips64el-linux-gnuabi64 cross-compiler on i686.
Fixes <http://bugs.gnu.org/19598>. Reported by Mark H Weaver <mhw@netris.org>. * gnu/packages/cross-base.scm (xgcc-mips64el): Remove "i686-linux" from 'supported-systems'.
Diffstat (limited to 'gnu/packages/cross-base.scm')
-rw-r--r--gnu/packages/cross-base.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index 794d925841..a062128a79 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
@@ -308,10 +308,15 @@ XBINUTILS and the cross tool chain."
;;;
(define-public xgcc-mips64el
- (let ((triplet "mips64el-linux-gnuabi64")) ; N64 ABI
- (cross-gcc triplet
- (cross-binutils triplet)
- (cross-libc triplet))))
+ (let* ((triplet "mips64el-linux-gnuabi64") ;N64 ABI
+ (xgcc (cross-gcc triplet
+ (cross-binutils triplet)
+ (cross-libc triplet))))
+ ;; Don't attempt to build this cross-compiler on i686;
+ ;; see <http://bugs.gnu.org/19598>.
+ (package (inherit xgcc)
+ (supported-systems (delete "i686-linux"
+ (package-supported-systems xgcc))))))
(define-public xgcc-avr
;; AVR cross-compiler, used to build AVR-Libc.