summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-26 00:57:21 +0200
committerMarius Bakke <marius@gnu.org>2022-07-27 12:31:26 +0200
commitc5837dfd8117ca93d161f3eb345b9974520eb7dd (patch)
tree3e8d9caef20d0b8ba610b410f5979e31333fd912 /gnu/packages/crates-io.scm
parent6f7b463cbb2418f8858b22bb23edb93c4ca34caa (diff)
downloadguix-patches-c5837dfd8117ca93d161f3eb345b9974520eb7dd.tar
guix-patches-c5837dfd8117ca93d161f3eb345b9974520eb7dd.tar.gz
gnu: rust-takeable-option: Add 0.5.0.
* gnu/packages/crates-io.scm (rust-takeable-option): Add 0.5.0. (rust-takeable-option-0.4): Inherit from it.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4d5c6070d5..55d89f6527 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -61392,19 +61392,18 @@ without a mutable reference.")
(description "This package lets you temporarily take a T from a &mut T.")
(license license:expat)))
-(define-public rust-takeable-option-0.4
+(define-public rust-takeable-option-0.5
(package
(name "rust-takeable-option")
- (version "0.4.0")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "takeable-option" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0hvd6vk4ksgg2y99498jw52ric4lxm0i6ygpzqm95gdrhvsxyynp"))))
+ "182axkm8pq7cynsfn65ar817mmdhayrjmbl371yqp8zyzhr8kbin"))))
(build-system cargo-build-system)
(home-page "https://docs.rs/takeable-option/")
(synopsis "Small wrapper around option")
@@ -61412,6 +61411,21 @@ without a mutable reference.")
"This package provides a small wrapper around option.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-takeable-option-0.4
+ (package
+ (inherit rust-takeable-option-0.5)
+ (name "rust-takeable-option")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "takeable-option" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hvd6vk4ksgg2y99498jw52ric4lxm0i6ygpzqm95gdrhvsxyynp"))))))
+
(define-public rust-tap-1
(package
(name "rust-tap")