summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-08-17 21:37:36 +0200
committerMarius Bakke <marius@gnu.org>2022-08-27 00:09:02 +0200
commit8ece2cf5713df0f58e6287214efed8f2b3035413 (patch)
tree6b8770b1ae616b0db0601236bb38383a8f9f594c /gnu/packages/crates-io.scm
parent58faf8069c9dc77da626a26b9f9ccd3bfc37b977 (diff)
downloadguix-patches-8ece2cf5713df0f58e6287214efed8f2b3035413.tar
guix-patches-8ece2cf5713df0f58e6287214efed8f2b3035413.tar.gz
gnu: rust-send-wrapper: Add 0.5.0.
* gnu/packages/crates-io.scm (rust-send-wrapper-0.5): New variable. (rust-send-wrapper-0.4): Inherit from it.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 17 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0b801a59fe..2a37db698a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -54488,17 +54488,17 @@ Semantic Versioning.")
(base32
"18vhypw6zgccnrlm5ps1pwa0khz7ry927iznpr88b87cagr1v2iq"))))))
-(define-public rust-send-wrapper-0.4
+(define-public rust-send-wrapper-0.5
(package
(name "rust-send-wrapper")
- (version "0.4.0")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "send_wrapper" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1l7s28vfnwdbjyrrk3lx81jy4f0dcrv4iwyah2wj6vndxhqxaf7n"))))
+ (base32 "1mwbg1nv36d5kdjb0iwmprz24km0m8ck08dn59gdngqdc77hl34k"))))
(build-system cargo-build-system)
(arguments `(#:skip-build? #t))
(home-page "https://github.com/thk1/send_wrapper")
@@ -54511,6 +54511,20 @@ also have to make sure that the wrapper is dropped from within the original
thread. If any of these constraints is violated, a panic occurs.")
(license (list license:expat license:asl2.0))))
+(define-public rust-send-wrapper-0.4
+ (package
+ (inherit rust-send-wrapper-0.5)
+ (name "rust-send-wrapper")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "send_wrapper" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1l7s28vfnwdbjyrrk3lx81jy4f0dcrv4iwyah2wj6vndxhqxaf7n"))))
+ (arguments `(#:skip-build? #t))))
+
(define-public rust-seq-io-0.3
(package
(name "rust-seq-io")