summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-17 15:55:21 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-11-22 19:44:35 +0200
commit7b5be01359a29943a92e0f38d0aa3dbb3765e924 (patch)
tree084b0a61e9e39b22cb0db5a57af71c6be84d2432 /gnu/packages/crates-io.scm
parentd3466b90b757d2d1d8cef8b7f22bd29b8494eb0a (diff)
downloadguix-patches-7b5be01359a29943a92e0f38d0aa3dbb3765e924.tar
guix-patches-7b5be01359a29943a92e0f38d0aa3dbb3765e924.tar.gz
gnu: Add rust-buffered-reader-0.9.
* gnu/packages/crates-io.scm (rust-buffered-reader-0.9): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index fad349afb5..ee8e500469 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -2748,6 +2748,35 @@ UTF-8.")
(base32
"0nzi9vqhl56ws8gq39f3aj4qjrr4l3g5lbkkcj8xq1x4cb74wq2r"))))))
+(define-public rust-buffered-reader-0.9
+ (package
+ (name "rust-buffered-reader")
+ (version "0.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "buffered-reader" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05rklfiia1k4c4ifpim08l22i0q0l3j9xdg2yh3njrp6w58z6z13"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bzip2" ,rust-bzip2-0.3)
+ ("rust-flate2" ,rust-flate2-1)
+ ("rust-libc" ,rust-libc-0.2))))
+ (home-page "https://sequoia-pgp.org/")
+ (synopsis "Super-powered Reader")
+ (description
+ "Like the @code{BufRead} trait, the @code{BufferedReader} trait has an
+internal buffer that is directly exposed to the user. This design enables two
+performance optimizations. First, the use of an internal buffer amortizes
+system calls. Second, exposing the internal buffer allows the user to work
+with data in place, which avoids another copy.")
+ (license license:gpl3)))
+
(define-public rust-build-const-0.2
(package
(name "rust-build-const")