summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-08-03 21:45:39 +0200
committerJakub Kądziołka <kuba@kadziolka.net>2020-08-04 15:57:35 +0200
commit67433457741b761f0da4ceec58c49564d1252d61 (patch)
tree2fdab333ac709879c77369c5db6c92af9513a797 /gnu/packages/crates-io.scm
parentaf656e964d56a4a89cc33ff40f226ee1f730fabf (diff)
downloadguix-patches-67433457741b761f0da4ceec58c49564d1252d61.tar
guix-patches-67433457741b761f0da4ceec58c49564d1252d61.tar.gz
gnu: rust-notify-4: Update to 4.0.15.
* gnu/packages/crates-io.scm (rust-notify-4): Update to 4.0.15. [cargo-inputs]: Remove rust-kernel32-sys-0.2, replace rust-inotify-0.6 with -0.7. [cargo-development-inputs]: Replace rust-tempdir-0.3 with rust-tempfile-3.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cf89bcfaa1..0680cd0d0d 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -14959,7 +14959,7 @@ with all line endings.")
(define-public rust-notify-4
(package
(name "rust-notify")
- (version "4.0.14")
+ (version "4.0.15")
(source
(origin
(method url-fetch)
@@ -14968,7 +14968,7 @@ with all line endings.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "12vpbg8j49196rxkm01hw2xfr0mk005ljmx0p9kwf6xj6gy2i5hr"))))
+ "1gadf8jf1vz7sip37rlwa66vw85ripy6977ibcfbiynii1v4mbl0"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -14976,15 +14976,14 @@ with all line endings.")
("rust-filetime" ,rust-filetime-0.2)
("rust-fsevent" ,rust-fsevent-0.4)
("rust-fsevent-sys" ,rust-fsevent-sys-2)
- ("rust-inotify" ,rust-inotify-0.6)
- ("rust-kernel32-sys" ,rust-kernel32-sys-0.2)
+ ("rust-inotify" ,rust-inotify-0.7)
("rust-libc" ,rust-libc-0.2)
("rust-mio" ,rust-mio-0.6)
("rust-mio-extras" ,rust-mio-extras-2)
("rust-walkdir" ,rust-walkdir-2)
("rust-winapi" ,rust-winapi-0.3))
#:cargo-development-inputs
- (("rust-tempdir" ,rust-tempdir-0.3))))
+ (("rust-tempfile" ,rust-tempfile-3))))
(home-page "https://github.com/passcod/notify")
(synopsis "Cross-platform filesystem notification library")
(description