summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-02 22:33:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-03 08:51:52 +0200
commit659ece59fff81ffaac83121dc2fc7bc6a5e9b622 (patch)
treee14d281f94e65dc4342420d372efb594d4310671 /gnu/packages/crates-io.scm
parent19781930b781813e61be1b77e8b6cd34c2868d62 (diff)
downloadguix-patches-659ece59fff81ffaac83121dc2fc7bc6a5e9b622.tar
guix-patches-659ece59fff81ffaac83121dc2fc7bc6a5e9b622.tar.gz
gnu: Add rust-shell-words-0.1.
* gnu/packages/crates-io.scm (rust-shell-words-0.1): New variable.
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1d4bc8ffcd..67b87bf1d5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -15747,6 +15747,27 @@ for the serde framework.")
"This package allows easy binding to, and loading of, shared libraries.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-shell-words-0.1
+ (package
+ (name "rust-shell-words")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "shell-words" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jnrw3f174974fsi2hg48l0klpy24767ib28w0xcvi2ll5axxb1r"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/tmiasko/shell-words")
+ (synopsis
+ "Process command line according to parsing rules of UNIX shell")
+ (description
+ "Process command line according to parsing rules of UNIX shell.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-shlex-0.1
(package
(name "rust-shlex")