summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:31:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:42:04 +0300
commit64c043e63a4be97f59fd1906c47973a74eedda67 (patch)
tree37b15dfb4830e4f874edca87b521b6e9cdc3c81b /gnu/packages/crates-io.scm
parentb1f763de54dc2b8e240d0f01f7948ce76f67243e (diff)
parent75af73e1b7ac58770122d8831faa3a8158638bb0 (diff)
downloadguix-patches-64c043e63a4be97f59fd1906c47973a74eedda67.tar
guix-patches-64c043e63a4be97f59fd1906c47973a74eedda67.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm142
1 files changed, 127 insertions, 15 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f1fd9f1fef..452a22f0f2 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2021 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2022 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2022 Evgenii Lepikhin <e.lepikhin@corp.mail.ru>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32382,6 +32383,29 @@ by inspecting the system for user preference.")
("rust-regex" ,rust-regex-1)
("rust-winapi" ,rust-winapi-0.3))))))
+(define-public rust-located-yaml-0.2
+ (package
+ (name "rust-located-yaml")
+ (version "0.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "located_yaml" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0xnx5al5v7d9syspj0irm22alwc3a9adikqxpbyyf6vsz3k8xilv"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-linked-hash-map" ,rust-linked-hash-map-0.5)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-yaml-rust" ,rust-yaml-rust-0.4))))
+ (home-page "https://github.com/johnlepikhin/located_yaml")
+ (synopsis "YAML parser with saved positions")
+ (description
+ "YAML parser which provides AST with saved tokens positions.")
+ (license (list license:expat))))
+
(define-public rust-lock-api-0.4
(package
(name "rust-lock-api")
@@ -34684,23 +34708,38 @@ file's MIME type by its extension.")
;; No copyright headers in the source code. LICENSE indicates gpl3.
(license license:gpl3)))
-(define-public rust-minimal-lexical-0.1
+(define-public rust-minimal-lexical-0.2
(package
(name "rust-minimal-lexical")
- (version "0.1.4")
+ (version "0.2.1")
(source
(origin
(method url-fetch)
(uri (crate-uri "minimal-lexical" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0xynhr97vyv5n5lls41dl7bfa3ba122lix9mqij1l7yprl6n6r4w"))))
+ (base32 "16ppc5g84aijpri4jzv14rvcnslvlpphbszc7zzp6vfkddf4qdb8"))))
(build-system cargo-build-system)
(home-page "https://github.com/Alexhuszagh/minimal-lexical")
- (synopsis "Fast float parsing conversion routines")
- (description "Fast float parsing conversion routines.")
+ (synopsis "Float parsing conversion routines")
+ (description "This is a minimal version of rust-lexical, meant to allow
+efficient round-trip float parsing. Minimal-lexical implements a correct, fast
+float parser.")
(license (list license:expat license:asl2.0))))
+(define-public rust-minimal-lexical-0.1
+ (package
+ (inherit rust-minimal-lexical-0.2)
+ (name "rust-minimal-lexical")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "minimal-lexical" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0xynhr97vyv5n5lls41dl7bfa3ba122lix9mqij1l7yprl6n6r4w"))))))
+
(define-public rust-miniz-oxide-0.4
(package
(name "rust-miniz-oxide")
@@ -37322,7 +37361,7 @@ implementation (which is unstable / requires nightly).")
(define-public rust-nom-7
(package
(name "rust-nom")
- (version "7.0.0")
+ (version "7.1.1")
(source
(origin
(method url-fetch)
@@ -37331,13 +37370,13 @@ implementation (which is unstable / requires nightly).")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1ha24yclw4m74gi9p5c3d68rhrrcb7qvkgicz153p5cahck9vzbz"))))
+ "0djc3lq5xihnwhrvkc4bj0fd58sjf632yh6hfiw545x355d3x458"))))
(build-system cargo-build-system)
(arguments
`(#:tests? #f ; Tests require example directory, not included in tarball.
#:cargo-inputs
(("rust-memchr" ,rust-memchr-2)
- ("rust-minimal-lexical" ,rust-minimal-lexical-0.1)
+ ("rust-minimal-lexical" ,rust-minimal-lexical-0.2)
("rust-version-check" ,rust-version-check-0.9))
#:cargo-development-inputs
(("rust-criterion" ,rust-criterion-0.3)
@@ -37548,6 +37587,30 @@ combinators library.")
(description "This package derives custom nom parsers from structs.")
(license (list license:expat license:asl2.0))))
+(define-public rust-nom-locate-4
+ (package
+ (name "rust-nom-locate")
+ (version "4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "nom_locate" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0186n5qbpiyhpas3nk8y4ynnbdghl4nx958bkq4a6a9hr8v48y9p"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bytecount" ,rust-bytecount-0.6)
+ ("rust-memchr" ,rust-memchr-2)
+ ("rust-nom" ,rust-nom-7)
+ ("rust-stable-deref-trait" ,rust-stable-deref-trait-1))))
+ (home-page "https://github.com/fflorent/nom_locate")
+ (synopsis "Special input type for nom to locate tokens")
+ (description "This crate provides the @code{LocatedSpan} struct that
+encapsulates the data.")
+ (license (list license:expat))))
+
(define-public rust-noop-proc-macro-0.3
(package
(name "rust-noop-proc-macro")
@@ -44339,23 +44402,30 @@ functions.")
(("rust-predicates-core" ,rust-predicates-core-0.9)
("rust-treeline" ,rust-treeline-0.1))))))
-(define-public rust-pretty-0.5
+(define-public rust-pretty-0.11
(package
(name "rust-pretty")
- (version "0.5.2")
+ (version "0.11.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "pretty" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1lzn7d60l79vsdwcfgrh6jmk193nzwh1j36r8p9cv3n8dyghs37n"))))
+ (base32 "1282l4pa9hhamvbnd5mjrwhdgcsjy1l1lj44i0m4pczsf1cd3br9"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-termcolor" ,rust-termcolor-0.3)
- ("rust-typed-arena" ,rust-typed-arena-1))))
+ `(#:cargo-inputs
+ (("rust-arrayvec" ,rust-arrayvec-0.5)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-termcolor" ,rust-termcolor-1)
+ ("rust-typed-arena" ,rust-typed-arena-2)
+ ("rust-unicode-segmentation" ,rust-unicode-segmentation-1))
+ #:cargo-development-inputs
+ (("rust-criterion" ,rust-criterion-0.3)
+ ("rust-difference" ,rust-difference-2)
+ ("rust-env-logger" ,rust-env-logger-0.9)
+ ("rust-tempfile" ,rust-tempfile-3))))
(home-page "https://github.com/Marwes/pretty.rs")
(synopsis "Pretty printing combinators for Rust")
(description
@@ -44363,6 +44433,24 @@ functions.")
particularly useful for printing structured recursive data like trees.")
(license license:expat)))
+(define-public rust-pretty-0.5
+ (package
+ (inherit rust-pretty-0.11)
+ (name "rust-pretty")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pretty" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1lzn7d60l79vsdwcfgrh6jmk193nzwh1j36r8p9cv3n8dyghs37n"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-termcolor" ,rust-termcolor-0.3)
+ ("rust-typed-arena" ,rust-typed-arena-1))))))
+
(define-public rust-pretty-assertions-0.7
(package
(name "rust-pretty-assertions")
@@ -54582,6 +54670,30 @@ using nested parameters, similar to those used by @code{qs} for Node, and
commonly used by Ruby on Rails via Rack.")
(license (list license:expat license:asl2.0))))
+(define-public rust-serde-regex-1
+ (package
+ (name "rust-serde-regex")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "serde_regex" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1pxsnxb8c198szghk1hvzvhva36w2q5zs70hqkmdf5d89qd6y4x8"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-regex" ,rust-regex-1))
+ #:cargo-development-inputs
+ (("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
+ (home-page "https://github.com/tailhook/serde-regex")
+ (synopsis "Serde wrapper to serialize regular expressions as strings")
+ (description "This package provides a serde wrapper, that can be used to
+serialize regular expressions as strings.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-serde-repr-0.1
(package
(name "rust-serde-repr")