summaryrefslogtreecommitdiff
path: root/gnu/packages/crates-graphics.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-27 14:15:52 +0200
committerMarius Bakke <marius@gnu.org>2022-07-27 16:13:37 +0200
commit0470b4b47452405907b70f27c7d048285be7f01e (patch)
tree94d117eb222517e9c2f12f52164933f13bcb59ba /gnu/packages/crates-graphics.scm
parent8764f1bffc3a6efb1ce11276ac232a051448f3d6 (diff)
downloadguix-patches-0470b4b47452405907b70f27c7d048285be7f01e.tar
guix-patches-0470b4b47452405907b70f27c7d048285be7f01e.tar.gz
gnu: rust-wayland-server: Add 0.29.4.
* gnu/packages/crates-graphics.scm (rust-wayland-server-0.29): New variable. (rust-wayland-server-0.28): Inherit from it.
Diffstat (limited to 'gnu/packages/crates-graphics.scm')
-rw-r--r--gnu/packages/crates-graphics.scm49
1 files changed, 41 insertions, 8 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 0c9b323295..2b30720120 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2828,17 +2828,17 @@ wayland-client crate for usable bindings.")
(base32
"17mp49v7w0p0x5ry628lj2llljnwkr9aj9g4bqqhfibid32jhf5z"))))))
-(define-public rust-wayland-server-0.28
+(define-public rust-wayland-server-0.29
(package
(name "rust-wayland-server")
- (version "0.28.3")
+ (version "0.29.4")
(source
(origin
(method url-fetch)
(uri (crate-uri "wayland-server" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "09jfdjfqhjfcpiz4csgh60ymfkmz1cl3jmxyzq9hzcp0kyyxix93"))))
+ (base32 "1wj8gf28dbjwb824i29wf3wr5r6wp6ssknjm9b5dnb1fah47mk66"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
@@ -2846,7 +2846,7 @@ wayland-client crate for usable bindings.")
("rust-downcast-rs" ,rust-downcast-rs-1)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-libc" ,rust-libc-0.2)
- ("rust-nix" ,rust-nix-0.18)
+ ("rust-nix" ,rust-nix-0.22)
("rust-parking-lot" ,rust-parking-lot-0.11)
("rust-scoped-tls" ,rust-scoped-tls-1))))
(inputs
@@ -2854,12 +2854,12 @@ wayland-client crate for usable bindings.")
rust-downcast-rs-1
rust-lazy-static-1
rust-libc-0.2
- rust-nix-0.18
+ rust-nix-0.22
rust-parking-lot-0.11
rust-scoped-tls-1
- rust-wayland-commons-0.28
- rust-wayland-scanner-0.28
- rust-wayland-sys-0.28))
+ rust-wayland-commons-0.29
+ rust-wayland-scanner-0.29
+ rust-wayland-sys-0.29))
(home-page "https://github.com/smithay/wayland-rs")
(synopsis
"Bindings to the standard C implementation of the wayland protocol")
@@ -2868,6 +2868,39 @@ wayland-client crate for usable bindings.")
the wayland protocol, server side.")
(license license:expat)))
+(define-public rust-wayland-server-0.28
+ (package
+ (inherit rust-wayland-server-0.29)
+ (name "rust-wayland-server")
+ (version "0.28.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "wayland-server" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "09jfdjfqhjfcpiz4csgh60ymfkmz1cl3jmxyzq9hzcp0kyyxix93"))))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-downcast-rs" ,rust-downcast-rs-1)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-nix" ,rust-nix-0.18)
+ ("rust-parking-lot" ,rust-parking-lot-0.11)
+ ("rust-scoped-tls" ,rust-scoped-tls-1))))
+ (inputs
+ (list rust-bitflags-1
+ rust-downcast-rs-1
+ rust-lazy-static-1
+ rust-libc-0.2
+ rust-nix-0.18
+ rust-parking-lot-0.11
+ rust-scoped-tls-1
+ rust-wayland-commons-0.28
+ rust-wayland-scanner-0.28
+ rust-wayland-sys-0.28))))
+
(define-public rust-wayland-server-0.23
(package
(inherit rust-wayland-server-0.28)