summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-22 20:12:40 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-22 20:14:15 +0100
commitf010692a274527303ea1feecd40bc20645a75c15 (patch)
tree22cf7ac9c4c3d97bb1f5eecc4e5d2bf281112582 /gnu/packages/cran.scm
parent980ae86e2e77bea5d9fa10f8d374f1878c643338 (diff)
downloadguix-patches-f010692a274527303ea1feecd40bc20645a75c15.tar
guix-patches-f010692a274527303ea1feecd40bc20645a75c15.tar.gz
gnu: Add r-plotfunctions.
* gnu/packages/cran.scm (r-plotfunctions): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 417bb10631..dd73676622 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1070,6 +1070,33 @@ accessibility from hue, saturation, and lightness value scaling using the
Chroma.js Color Palette Helper. See @url{https://gka.github.io/palettes}.")
(license license:cc0)))
+(define-public r-plotfunctions
+ (package
+ (name "r-plotfunctions")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "plotfunctions" version))
+ (sha256
+ (base32 "0asmxw8283fpvl83h478j5nyg59xqifqaa8f2f6l199gvvswhhg2"))))
+ (properties `((upstream-name . "plotfunctions")))
+ (build-system r-build-system)
+ (native-inputs (list r-knitr))
+ (home-page "https://jacolienvanrij.com/tutorials.html")
+ (synopsis "Various functions to facilitate visualization of data and analysis")
+ (description
+ "When analyzing data, plots are a helpful tool for visualizing data and
+interpreting statistical models. This package provides a set of simple tools
+for building plots incrementally, starting with an empty plot region, and
+adding bars, data points, regression lines, error bars, gradient legends,
+density distributions in the margins, and even pictures. The package builds
+further on R graphics by simply combining functions and settings in order to
+reduce the amount of code to produce for the user. As a result, the package
+does not use formula input or special syntax, but can be used in combination
+with default R plot functions.")
+ (license license:gpl2+)))
+
(define-public r-ecp
(package
(name "r-ecp")