summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-06-25 10:11:42 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-06-25 10:11:42 +0200
commitef9ad872150629f0a757e17f4cef834950b3e4ee (patch)
treef37728e0813c4cf19fb5b3791ee521a00f5f2424 /gnu/packages/cran.scm
parente5a05d9d8011b881b39beca350ef9b4a24d4901c (diff)
downloadguix-patches-ef9ad872150629f0a757e17f4cef834950b3e4ee.tar
guix-patches-ef9ad872150629f0a757e17f4cef834950b3e4ee.tar.gz
gnu: Add r-tzdb.
* gnu/packages/cran.scm (r-tzdb): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index f888bbcfab..6b3a4d03df 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29451,3 +29451,34 @@ complex functions.")
providing a range of new grammar classes that can be added to the plot object
in order to customise how it should change with time.")
(license license:expat)))
+
+;; This library bundles ‘date’ from (gnu packages calendar). We cannot unbundle
+;; it, because its C++ libtz.so is built with different compiler flags than
+;; ours.
+(define-public r-tzdb
+ (package
+ (name "r-tzdb")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tzdb" version))
+ (sha256
+ (base32
+ "0ym5rh6abs8ash6xz0av0gfhsjp7k1lgnjvpba36zwrxyfg2wrqi"))))
+ (properties `((upstream-name . "tzdb")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-cpp11" ,r-cpp11)))
+ (home-page "https://github.com/r-lib/tzdb")
+ (synopsis "Time Zone Database Information")
+ (description
+ "This package provides an up-to-date copy of the Internet Assigned
+Numbers Authority (IANA) Time Zone Database. It is updated periodically to
+reflect changes made by political bodies to time zone boundaries, UTC offsets,
+and daylight saving time rules. Additionally, this package provides a C++
+interface for working with the @code{date} library. @code{date} provides
+comprehensive support for working with dates and date-times, which this package
+exposes to make it easier for other R packages to utilize. Headers are
+provided for calendar specific calculations, along with a limited interface for
+time zone manipulations.")
+ (license license:expat)))