summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-06-04 16:07:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-06-05 09:12:39 +0200
commitd5c08f11e1c17a10625d413b1aa7350218f61dfc (patch)
tree1f874b0493703dcd97cdfe12a86a922d5dd7fb0d /gnu/packages/cran.scm
parentc343c3bc1f1310ca1075491ed48fe2db16b978a7 (diff)
downloadguix-patches-d5c08f11e1c17a10625d413b1aa7350218f61dfc.tar
guix-patches-d5c08f11e1c17a10625d413b1aa7350218f61dfc.tar.gz
gnu: Add r-aplot.
* gnu/packages/cran.scm (r-aplot): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ab21707d92..eee883a0c7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17673,6 +17673,33 @@ making it possible to download files over HTTPS across platforms. The
external dependencies. This package has is implemented purely in R.")
(license license:gpl2)))
+(define-public r-aplot
+ (package
+ (name "r-aplot")
+ (version "0.0.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "aplot" version))
+ (sha256
+ (base32
+ "08kqrm9r57l8zgij897wpp428l4i50qfhp7y78r3pk5pjz37bsan"))))
+ (properties `((upstream-name . "aplot")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-magrittr" ,r-magrittr)
+ ("r-patchwork" ,r-patchwork)))
+ (home-page "https://github.com/YuLab-SMU/aplot")
+ (synopsis "Decorate a ggplot with associated information")
+ (description
+ "Users may want to align plots with associated information that requires
+axes to be exactly matched in subplots, e.g. hierarchical clustering with a
+heatmap. This package provides utilities to align associated subplots to a
+main plot at different sides (left, right, top and bottom) with axes exactly
+matched.")
+ (license license:artistic2.0)))
+
(define-public r-rex
(package
(name "r-rex")