summaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-16 09:17:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-16 09:33:53 +0200
commitb1a7a3bb78e3f47af04019ce7a8a1738a4b64366 (patch)
tree030cc94af792044eb817fbfc2a0dbcbaa474c0fb /gnu/packages/cran.scm
parentaee8cc0a0d25fa8efccff825f1768d97fedadbbd (diff)
downloadguix-patches-b1a7a3bb78e3f47af04019ce7a8a1738a4b64366.tar
guix-patches-b1a7a3bb78e3f47af04019ce7a8a1738a4b64366.tar.gz
gnu: Add r-entropy.
* gnu/packages/cran.scm (r-entropy): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4afe9d489c..3d5027971b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6688,6 +6688,31 @@ Functions are provided for the construction of confidence intervals for the
reduced-bias estimates.")
(license license:gpl2+)))
+(define-public r-entropy
+ (package
+ (name "r-entropy")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "entropy" version))
+ (sha256
+ (base32
+ "10vg4818q5g54pv2nn9x5i7pvky5nsv96syy47pz2mgqp1273cpd"))))
+ (properties `((upstream-name . "entropy")))
+ (build-system r-build-system)
+ (home-page "https://www.strimmerlab.org/software/entropy/")
+ (synopsis "Estimation of entropy, mutual information and related quantities")
+ (description
+ "This package implements various estimators of entropy, such as the
+shrinkage estimator by Hausser and Strimmer, the maximum likelihood and the
+Millow-Madow estimator, various Bayesian estimators, and the Chao-Shen
+estimator. It also offers an R interface to the NSB estimator. Furthermore,
+it provides functions for estimating Kullback-Leibler divergence, chi-squared,
+mutual information, and chi-squared statistic of independence. In addition
+there are functions for discretizing continuous random variables.")
+ (license license:gpl3+)))
+
(define-public r-abn
(package
(name "r-abn")